Meteor 1.5.1 -> Meteor 1.5.2 cause empty __meteor_runtime_config__


#1

After upgrading to Meteor 1.5.2, I am experiencing a strange bug! meteor_runtime_config is empty!

the html page http://localhost:3000/ contains:

<script type="text/javascript">
__meteor_runtime_config__ = JSON.parse(decodeURIComponent(<%= conf %>))
</script>
  <script type="text/javascript" src="<%- src %>"></script>
  <script type="text/javascript" src="<%- src %>"></script>
...

later I tried with: meteor reset
and also a downgrade: meteor update --release 1.5.1

but the issue persist!!

do you know how I can completely restore the previous version?
I can not understand how I can investigate the problem! :frowning:
(nodejs --version is v8.5.0)

many thanks


#2

Did you ever find the problem?

I’m getting the same issue and couldn’t resolve it. I’ve stayed on 1.5.1 (I was able to revert to an earlier commit in git and it worked again for me), and any upgrade to 1.5.2 or now 1.6 and I get the exact same error…

EDIT:
After painstaking adding/removing packages, I managed to narrow it down to the alanning:elasticsearch package.
Once I removed this, everything worked again. The three packages that it removed were:
alanning:elasticsearch
alanning:update-helpers
meteorhacks:async

My hunch is meteorhacks:async is likely the real problem, because it’s an old package (pre-ES6) that messes with sync and async javascript calls, so it’s probably conflicting with new ES6 promises and other features.

Anyway, for now, I’ve removed that package and everything works. Now I just have to find an npm package to replace that functionality :slight_smile:
Hope this helps!


#3

yes @mraju

I have opened an issue in Meteor Github here:

The cause is in the last updates into boilerplate-generator.

Some developers working about a general solution.