Meteor 1.5.2 shell not working [SOLVED]


#1

I created a little test project to work with dynamic imports and noticed that the shell command is not working anymore

jhm at macpro in ~/M/test152                                                                                                    11:14:39
 meteor run
[[[[[ ~/Meteor/test152 ]]]]]                  

=> Started proxy.                             
                                              
Changes to your project's package version selections:
                                              
bundle-visualizer  removed from your project  

=> Started MongoDB.                           
=> Started your app.                          

=> App running at: http://localhost:3000/

and in a different window

jhm at macpro in ~/M/test152                                                                                                    11:14:20
 meteor shell 
Server unavailable (waiting to reconnect)

what am I missing?


#2

Just tried a fresh project on 1.5.2 and meteor shell worked without issue.

Can you check if you have the package shell-server in your .meteor/packages list?

Maybe try forcing meteor to add it again: meteor add shell-server


#3

Thank you, that was indeed the solution.