Meteor 1.6.1_1 download running forever


#1

I did “meteor update” and have been looking at “Downloading meteor-tool@1.6.1_1…” for the past 90 minutes. The project was previously updated to 1.6. so this very long download is unexpected. Considering that I was planning to work on the project during that 90 minutes, it is an unwelcome surprise…


#2

Are you using Windows?

If so, check this post:


#3

Yes, I am using Windows 8.1 with Norton anti-virus software. I left the meteor update running all day, and it was hung when I got home. The console showed various EPERM unlink not permitted error messages, followed by a list of changes to the project package versions, then a message about an available moment update that may be incompatible, then “To update one or more packages…” then nothing. I had to use task manager to kill it.

When I started meteor, I got “Error: Cannot find module ‘@babel/runtime/helpers/builtin/objectSpread’”. I googled that and found a fix: " npm install --save-dev babel-plugin-transform-object-rest-spread".

I will fool with the anti-virus software next time I have to do a meteor update. Thanks for the hint.


#4

I spoke too soon. That fix did not work; I still get the “cannot find module … objectspread” error. Sigh. I hate this kind of problem. I’ll update here when I find a real fix.


#5

I’ve had the same problem in various Windows machine with Meteor for couple of years. Downloading meteor tool… I’m using mac or linux now and its working great!


#6

the object spread error is fixed by

meteor npm install @babel/runtime

EPERM errors are hell. If you keep getting them you may need to wipe the directory it was talking about


#7

“meteor npm install …” gets me:

npm ERR! Error while executing:
npm ERR! C:\Program Files\Git\cmd\git.EXE ls-remote -h -t https://github.com/meteor/readab
npm ERR!
npm ERR! fatal: Unable to find remote helper for 'https'
npm ERR!
npm ERR! exited with error code: 128

Fortunately, “npm install” still works so I’ve been using that.

This kind of thing has been the major downside of using Meteor for me. It’s not just this update. I’ve had things like this 2 or 3 times before, and they have each absorbed a day or two of time. This experience makes me think that I should not use Meteor for new projects. The productivity benefits of the Meteor architecture are overcome by these kinds of install problems.


#8

That worked!!! Thanks so much. Now I can get back to productive work.