Meteor 1.6.1.3 patch update - Potentially incompatible change required to top-level dependency errors?


#1

Hi

I just tried updating my Meteor 1.6.1.1 project to the 1.6.1.3 patch.

tldr; meteor update --patch didn’t work - but meteor update --release 1.6.1.3 did work!

I tried updating using meteor update --patch (as suggested when Meteor starts up)

I noticed that it downloaded meteor tool 1.7 and the “patch” also seemed to include a lot of Meteor package updates for a minor point release.

$ meteor update --patch

Changes to your project's package version selections from updating the release:
                                              
accounts-password          upgraded from 1.5.0 to 1.5.1
babel-compiler             upgraded from 7.0.8 to 7.1.1
babel-runtime              upgraded from 1.2.0 to 1.2.2
base64                     upgraded from 1.0.10 to 1.0.11
boilerplate-generator      upgraded from 1.4.0 to 1.5.0
caching-compiler           upgraded from 1.1.9 to 1.1.12
check                      upgraded from 1.3.0 to 1.3.1
ddp-client                 upgraded from 2.3.1 to 2.3.2
ddp-server                 upgraded from 2.1.2 to 2.2.0
dynamic-import             upgraded from 0.3.0 to 0.4.0
ecmascript                 upgraded from 0.10.6 to 0.11.1
ecmascript-runtime         upgraded from 0.5.0 to 0.7.0
ecmascript-runtime-client  upgraded from 0.6.0 to 0.7.1
ecmascript-runtime-server  upgraded from 0.5.0 to 0.7.0
es5-shim                   upgraded from 4.7.0 to 4.8.0
http                       upgraded from 1.4.0 to 1.4.1
logging                    upgraded from 1.1.19 to 1.1.20
meteor                     upgraded from 1.8.2 to 1.9.0
meteor-base                upgraded from 1.3.0 to 1.4.0
minifier-css               upgraded from 1.3.0 to 1.3.1
minimongo                  upgraded from 1.4.3 to 1.4.4
modern-browsers            added, version 0.1.1
modules                    upgraded from 0.11.3 to 0.12.0
modules-runtime            upgraded from 0.9.1 to 0.10.0
mongo                      upgraded from 1.4.2 to 1.5.0
mongo-id                   upgraded from 1.0.6 to 1.0.7
npm-mongo*                 upgraded from 2.2.33 to 3.0.7
promise                    upgraded from 0.10.1 to 0.11.1
rate-limit                 upgraded from 1.0.8 to 1.0.9
routepolicy                upgraded from 1.0.12 to 1.0.13
server-render              removed from your project
shim-common                removed from your project
socket-stream-client       upgraded from 0.1.0 to 0.2.1
standard-minifier-css      upgraded from 1.4.0 to 1.4.1
standard-minifier-js       upgraded from 2.3.3 to 2.3.4
tracker                    upgraded from 1.1.3 to 1.2.0
webapp                     upgraded from 1.5.0 to 1.6.0

* These packages have been updated to new versions that are not backwards
compatible.
app: updated to Meteor 1.6.1.3.               
                                              
-- Notice --                                  
                                              
1.7: The underscore package has been removed as a dependency of all packages in meteor-base. Since some apps may have been using underscore through this dependency without having it listed in their .meteor/packages files, it has
     been added automatically. If your app is not using underscore, then you can safely remove it using 'meteor remove underscore'.

I also note the 1.7 auto-update notice about underscore which seemed odd for a 1.6.1.3 patch.

When I try to restart my app, it now complains about Potentially incompatible change required to top-level dependency:

Errors prevented startup:
   
   While selecting package versions:
   error: Potentially incompatible change required to top-level dependency:
   mongo 1.4.7, was 1.5.0.
   Constraints on package "mongo":
   * mongo@1.4.2 <- top level
   * mongo@~1.4.2 <- top level
   * mongo@1.4.2 <- autoupdate 1.4.0 <- hot-code-push 1.0.4 <- meteor-base
... 100+ more lines like this including a few other top-level packages, like es5-shim, ecmascript, ...

It feels like it has installed packages for Meteor 1.7, but patched Meteor core to 1.6.1.3

I ran meteor update --release 1.6.1.1 to downgrade back to Meteor 1.6.1.1 and everything worked again.

I then ran meteor update --release 1.6.1.3 and it installed JUST the Meteor 1.6.1.3 patch I wanted - without updating the other Meteor packages.

Not sure if the instructions to run meteor update --patch are behaving as expected now that Meteor 1.7 is released?


#2

Have you created an issue on the github repo? https://github.com/meteor/meteor/issues/


#3

Good idea - filed: https://github.com/meteor/meteor/issues/10008


Update to 1.6.3 failing [Solved]
Meteor patch update BROKE my build!
#4

[Solved]Unable to resolve some modules:

@babel/runtime/helpers/builtin/interopRequireDefault” in /Users/m_712199/Local_Dev/esmerlin-config/shared/imports/collection-helpers/users.js (os.osx.x86_64)
@babel/runtime/helpers/builtin/objectSpread” in /Users/m_712199/Local_Dev/esmerlin-config/shared/imports/collection-helpers/users.js (os.osx.x86_64)

If you notice problems related to these missing modules, consider running:

meteor npm install --save @babel/runtime

W20180808-17:16:24.978(-7)? (STDERR) /Users/m_712199/Local_Dev/esmerlin-config/.meteor/local/build/programs/server/boot.js:475
W20180808-17:16:24.979(-7)? (STDERR) }).run();
W20180808-17:16:24.979(-7)? (STDERR) ^
W20180808-17:16:24.979(-7)? (STDERR)
W20180808-17:16:24.979(-7)? (STDERR) Error: Cannot find module ‘@babel/runtime/helpers/builtin/interopRequireDefault’
W20180808-17:16:24.979(-7)? (STDERR) at Function.Module._resolveFilename (module.js:547:15)
W20180808-17:16:24.980(-7)? (STDERR) at Function.resolve (internal/module.js:18:19)
W20180808-17:16:24.980(-7)? (STDERR) at Object.require (/Users/m_712199/Local_Dev/esmerlin-config/.meteor/local/build/programs/server/boot.js:288:32)
W20180808-17:16:24.980(-7)? (STDERR) at makeInstallerOptions.fallback (packages/modules-runtime.js:651:18)
W20180808-17:16:24.980(-7)? (STDERR) at require (packages/modules-runtime.js:244:16)
W20180808-17:16:24.980(-7)? (STDERR) at livedata_connection.js (/Users/m_712199/Local_Dev/esmerlin-config/.meteor/local/build/programs/server/packages/ddp-client.js:147:30)
W20180808-17:16:24.980(-7)? (STDERR) at fileEvaluate (packages/modules-runtime.js:343:9)
W20180808-17:16:24.981(-7)? (STDERR) at require (packages/modules-runtime.js:238:16)
W20180808-17:16:24.981(-7)? (STDERR) at namespace.js (packages/ddp-client/common/namespace.js:1:300)
W20180808-17:16:24.981(-7)? (STDERR) at fileEvaluate (packages/modules-runtime.js:343:9)

Seeing this error after updated to 1.6.3.1 @steveovens any idea?


#5

Hi @saig - looks like a different error now.

I assume you have tried the instruction to: meteor npm install --save @babel/runtime

I’ve had these kinds of babel errors before - usually a meteor reset, installing any missing npm packages and then running meteor npm install to ensure that they are all installed will sort things out.

Hopefully one of these steps will help.

If none of the above helps, then you might be best logging this as a separate topic in the forum so it’s not buried in an unrelated issue - perhaps someone else can offer more ideas on this one.

Good luck

Steve