Meteor 1.6 not running on Windows 10


#1

I’ve created a new app (meteor create newapp) and everything looks fine, but when I run meteor I get the following error:

Error: Cannot find module 'fibers'
at Function.Module._resolveFilename (module.js:513:15)
at Function.Module._load (module.js:463:25)
at Module.require (module.js:556:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (E:\Users\New User\meteor\3.7.4c\.meteor\local\build\programs\server\boot.js:1:75)
at Module._compile (module.js:612:30)
at Object.Module._extensions..js (module.js:623:10)
at Module.load (module.js:531:32)
at tryModuleLoad (module.js:494:12)
at Function.Module._load (module.js:486:3)

Node.js has been upgraded to version 8.8.1

So it creates the app with Meteor 1.6, but won’t run the app.
Any suggestions?


#2

Reinstall NodeJS maybe


#3

Thanks - I tried that, and somewhere on the forums, I read that I need to be running the same version as Meteor which is 8.8.1 (I believe) which is shown in the error message.


#4

Wasn’t there an issue with long path names / spaces in path names?


#5

I think that had more to do with installing Meteor - I can install it, it just won’t run. I’m having no problem with 1.5.4 - I just want to update to 1.6


#6

The space character in the path (\New User\) looks worrisome to me. Maybe rename that user to NewUser and see if it helps.


#7

Guys, it’s not a space in the Windows $PATH problem lol, this isn’t Node 0.x.

Your best bet is doing a fresh install of your NPM packages, or reinstalling Meteor and/or Node, worst case.


#8

I have been trying for weeks to get meteor to work natively on Windows (was on WSL but there’s problems with that w/ new mongo version). I get “Cannot find module ‘fibers’” no matter what I do. I have removed meteor and node and re-installed with choco. Any suggestions?