Meteor 1.8.1 too slow

I swtiched to Meteor 1.8.1, but ironically, now application has become too slow to load (way too noticeably slow). Is anyone else facing this issue. If not then what could I be doing wrong?

The details are, now Iam using, meteor 1.8.1, meteor uses node v8.15.1 (I probably dont need to give this info, but anyway).

I fetch about few hundreds of KB of data for a page. But this page now takes 10-15 seconds to load, whereas previously it took less than 5 seconds to load.

Any help would be greatly appreciated.


Is there anything else you have changed? Updated any other packages, etc. What are the packages that you are using?

I think its the nodejs version. When I run the meteor build of my project on staging machine which has nodejs v8.6.0, the app is fast. However when I run the meteor build on my local machine, it uses nodejs v8.15.1 which makes my app slow.

I think nodejs v8.15.1 is causing some issues for my app. Should this behavior be due to packages Iam using? My package.json file is below. Also, is it possible to change nodejs version used by meteor on local dev machine?

Any help would be greatly appreciated.


    "@babel/runtime": "^7.2.0",
    "async": "^2.6.2",
    "aws-sdk": "^2.308.0",
    "babel-runtime": "^6.26.0",
    "bluebird": "^3.5.1",
    "body-parser": "^1.18.2",
    "bootbox": "^4.4.0",
    "bootstrap-alerts": "^1.2.2",
    "bootstrap-select": "^1.12.4",
    "bootstrap-slider": "^9.10.0",
    "buffer": "^5.0.8",
    "core-decorators": "^0.20.0",
    "escape-html": "^1.0.3",
    "google-auth-library": "^0.11.0",
    "google-id-token-verifier": "^0.2.3",
    "googleapis": "^22.2.0",
    "gps-util": "^1.0.1",
    "html-to-text": "^4.0.0",
    "ip": "^1.1.5",
    "jquery": "^2.2.3",
    "mac-address": "^0.3.0",
    "mailparser": "^2.1.0",
    "math": "0.0.3",
    "meteor-node-stubs": "^0.4.1",
    "mikronode": "^2.3.6",
    "moment": "^2.19.1",
    "moment-timezone": "^0.5.14",
    "mongodb_s3_backup": "^0.0.8",
    "net-snmp": "^1.2.0",
    "node-email-reply-parser": "^0.1.1",
    "node-ssh": "^5.0.0",
    "nodemailer": "^4.4.0",
    "p-all": "^1.0.0",
    "p-any": "^1.1.0",
    "p-series": "^1.1.0",
    "p-wait-for": "^1.0.0",
    "p-whilst": "^1.0.0",
    "ping": "^0.2.2",
    "querystring": "^0.2.0",
    "request": "^2.87.0",
    "request-promise-native": "^1.0.5",
    "rxjs": "^5.5.7",
    "scp2": "^0.5.0",
    "simpl-schema": "^0.4.0",
    "ssh2": "^0.5.5",
    "stripe": "^5.3.0",
    "tcp-ping": "^0.1.1",
    "underscore": "^1.8.3",
    "uservoice": "^0.4.1"
       "@meteorjs/eslint-config-meteor": "^1.0.5",
    "babel-eslint": "^8.0.2",
    "eslint": "^4.11.0",
    "eslint-config-airbnb": "^16.1.0",
    "eslint-import-resolver-meteor": "^0.4.0",
    "eslint-plugin-import": "^2.8.0",
    "eslint-plugin-jsx-a11y": "^6.0.2",
    "eslint-plugin-meteor": "^4.1.6",
    "eslint-plugin-react": "^7.4.0"

The only way to change Node version for Meteor is to downgrade or upgrade. Give Meteor 1.8.2-rc.3 a try.

1 Like

Yeah 1.8.2-rc.3 works like a charm. 1.8.2.-rc.3 uses nodejs v8.16.1. So my issue seems like nodejs v8.15.1 is not compatible with some of the packages Iam using.

Thanks a lot for help. Any idea when meteor 1.8.2 will be officially released?

Also someone who wants to install meteor 1.8.2-rc.3 the command is,

meteor update --release 1.8.2-rc.3