Meteor 1.+ With Cordova 9 enable Google-Services / AndroidX

With Cordova 9 new options to enable google-services without adding a plugin, has anyone tried these settings vs using cordova-support-google-services which is now deprecated?

https://cordova.apache.org/announcements/2020/06/29/cordova-android-9.0.0.html

support for:

  • The default target SDK version is set to 29.
  • The minimum SDK version is set to 22.
  • The minimum supported Android version is 5.1.