Meteor 2.5.1 is here! Includes M1 support 💻

Hey everyone!

Meteor 2.5.1 is now out and recommended. See highlights below!

Highlights:
• Native Mac M1 support
• Breaking change in accounts-passwordless package

For more details, check out the link here.

Please let us know if you have any questions!

13 Likes

Just unpacked my new macbook pro, installed node via brew, installed meteor, created a new project an d got this:

jan-michaelpilgenroeder@MacBook-Pro test % meteor
[[[[[ ~/Code/test ]]]]]

=> Started proxy.
=> Started HMR server.
arch: posix_spawnp: /Users/jan-michaelpilgenroeder/.meteor/packages/meteor-tool/.2.5.1.1t0zdzb.asmeh++os.osx.arm64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.arm64/dev_bundle/mongodb/bin/mongod: Bad
CPU type in executable
Unexpected mongo exit code 1. Restarting.
arch: posix_spawnp: /Users/jan-michaelpilgenroeder/.meteor/packages/meteor-tool/.2.5.1.1t0zdzb.asmeh++os.osx.arm64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.arm64/dev_bundle/mongodb/bin/mongod: Bad
CPU type in executable
Unexpected mongo exit code 1. Restarting.
arch: posix_spawnp: /Users/jan-michaelpilgenroeder/.meteor/packages/meteor-tool/.2.5.1.1t0zdzb.asmeh++os.osx.arm64+web.browser+web.browser.legacy+web.cordova/mt-os.osx.arm64/dev_bundle/mongodb/bin/mongod: Bad
CPU type in executable
Unexpected mongo exit code 1. Restarting.
Can't start Mongo server.
MongoDB failed global initialization
jan-michaelpilgenroeder@MacBook-Pro test %
1 Like

Have you installed Rosetta? Mongo is running on top of rosetta.

You can run:

/usr/sbin/softwareupdate --install-rosetta --agree-to-license

4 Likes

that did the trick. thanks

1 Like

Time to buy a new MacBook Pro

1 Like

Damn, that thing is scary fast. We really will have to remember to take extra care not to build stuff that performs like crap on “regular” hardware.

3 Likes

Thanks a lot for native M1 compatibility, this is a real game changer.

I managed to upgrade all my projects flawlessly - except for a few older ones that were still relying on iron:router, which makes use of deprecated syntax like UI.registerHelper instead of Template.registerHelper and raises errors in Meteor 2.5.1.

Replacing iron:router with ostrio:flow-router-extra and changing a few instructions in the routes solved the problem.

Again, a big thank you to the Meteor team !

2 Likes

This is awesome!! Nice going guys

1 Like

You shouldn’t have problems with iron:router.

After this update it should be compatible.

Where exactly is this error happening?

3 Likes

Hey there,
I am new to the meteor ecosystem and just tried to update, however I get an error. I started with 2.3.5 then shortly after tried to run meteor update in Rosetta on my M1 but it failed unfortunately as shown below:

Any hint/idea about what I am doing wrong?

giphy
So much speed! This is seriously great, thank you, everyone involved :partying_face:

3 Likes

Hi, please read the section How To Upgrade.

It is important to upgrade your app without the new Meteor (with M1) installed, as Meteor needs the previous version in order to update your app.

This is never going to happen again because Meteor manages the versions for you but in this case, as this is the first version for this architecture, you need to use the previous version first.

Ah great, thank you for your rapid response!

Best,
Andrea

Hi @filipenevola ,

Thanks, and sorry for being late - I just noticed your answer. The problem was occurring when trying to launch Meteor in development mode, making it crash with an error message saying something like ‘UI is undefined’.

I first forked iron:router locally and started by replacing UI.registerHelper with
Template.registerHelper in a few lines, but since it didn’t seem to be sufficient I switched to FlowRouter.

I guess the new iron:router version wasn’t yet available on Atmosphere by the time I upgraded Meteor.