Meteor 3.0-alpha.20 is out!

Hey! We have great news! Meteor v3.0-alpha.20 is out!
You can test it by running:

meteor update --release 3.0-alpha.20

In this release, we have a few great additions:

  • Call async is now working correctly pr

How is working now

For testing the changes, you can check this snippet:

// Method created on the client
  getData() {
    return "not data for the client";

// Method created on the server
  getData() {
    return LinksCollection.find().fetch();

// Calling method on the client
const promise = Meteor.callAsync('getData');
console.log('getData SERVER', await promise); // Logs data returned from the server
console.log('getData CLIENT', await promise.stubPromise); //  Logs "not data for the client"
  • moved compileForShell from ecmascript pr
  • All changes that came in 2.14 are now in 3.0 pr

Do you think it’s right time to upgrade existing app to version 3.0?

Looking at the Meteor 3.0 task list, there are still a number of items to fix:

Although, seems like a beta version is about to be released. Beta versions should be ok for broader testing/preparation for apps. But I don’t think it is prime for production at its current status


Everyone: Please raise a hand if you manage to build this version for production.

I’ll be trying that first thing in the new year if I’m not too sick.

Tried to build Beta0 for production. TypeError: “Column must be greater than or equal to 0, got -16”
Same issue as in alpha15.

Hi in case useful and any insights/advice>>
upgrade attempt on existing project with vue front end and in METEOR@2.14.
fibers/async changes were done and working before upgrade attempt

% meteor update --release=3.0-alpha.20

=> Errors while initializing project:         
While selecting package versions:
error: Conflict: Constraint caching-compiler@1.0.5 is not satisfied by
caching-compiler 2.0.0-alpha300.20.
Constraints on package "caching-compiler":
* caching-compiler@~2.0.0-alpha300.20 <- top level
* caching-compiler@2.0.0-alpha300.17 <- caching-html-compiler
2.0.0-alpha300.17 <- static-html 1.3.3-alpha300.20
* caching-compiler@1.0.5 <- akryum:vue-component 0.3.5

Conflict: Constraint babel-compiler@6.8.0 is not satisfied by babel-compiler
Constraints on package "babel-compiler":
* babel-compiler@~7.11.0-alpha300.20 <- top level
* babel-compiler@7.11.0-alpha300.20 <- ecmascript 0.16.8-alpha300.20
* babel-compiler@7.11.0-alpha300.20 <- typescript 4.9.5-alpha300.20 <- logging
1.3.3-alpha300.20 <- mongo 2.0.0-alpha300.20
* babel-compiler@7.11.0-alpha300.20 <- minifier-js 3.0.0-alpha300.20 <-
standard-minifier-js 3.0.0-alpha300.20
* babel-compiler@7.11.0-alpha300.20 <- shell-server 0.6.0-alpha300.20
* babel-compiler@6.8.0 <- akryum:vue-component 0.3.5
* babel-compiler@7.3.4 <- coffeescript-compiler 2.4.1 <- akryum:vue-coffee

I can see the package: akryum:vue-component needs to be updated

Thanks Minha !, hope you had a great holiday break.

Things Ive tried:
I started with app working in METEOR@2.14 which is great! next,
meteor update akryum:vue-component
akryum:vue-component upgraded from 0.15.2 to 0.16.0
So far so good ; )

Now I think I need upgrade to vue-component@0.3.5
I manually edit relevant lines in
.meteor/packages AND in .meteor/versions
akryum:vue-component@0.3.5 ( Also tried deleting the .meteor/local folder when I had issues, no change) Now when I launch app I see => Errors prevented startup:

=> Errors prevented startup:                  
   While loading plugin `vue-component` from package `akryum:vue-component`:
   internal/modules/cjs/loader.js:933:15: Cannot find module
   Require stack:
   at Function.Module._resolveFilename (internal/modules/cjs/loader.js:933:15)
   at Function.Module._load (internal/modules/cjs/loader.js:776:27)
   at Module.require (internal/modules/cjs/loader.js:1005:19)
   at require (internal/modules/cjs/helpers.js:107:18)
   at Object.require (/tools/isobuild/bundler.js:2191:22)
   at makeInstallerOptions.fallback (packages/modules-runtime.js:651:18)
   at require (packages/modules-runtime.js:244:16)
   at tag-handler.js (<runJavaScript-43>:615:16)
   at fileEvaluate (packages/modules-runtime.js:343:9)
   at require (packages/modules-runtime.js:238:16)
   at <runJavaScript-43>:26184:1
   at <runJavaScript-43>:26191:3 

Also I see the attempt to run the app has changed version back to  akryum:vue-component@0.13.0

should I be trying to upgrade after the
meteor update --release=3.0-alpha.20
(seemed to face problems also)