Meteor add-platform ios MISSING COCOAPODS?


Quite new to meteor, so far so good but I just tried to add IOS platform to one of my app and I get this message : "Your system does not yet seem to fulfill all requirements to build apps for iOS.

Please follow the installation instructions in the mobile guide:

Status of the individual requirements:
✓ Apple OS X
✓ Xcode
✗ CocoaPods"

Now even on apps that were already running on IOS I get the same message. Before everything was fine and I could run my iOS app without problems.
Anyone knows why I get that ?

(could that be related to one npm package that i installed with required a c-complier ??)

Thanks a lot for your help !

Have you upgraded Meteor recently? I got the same error after an upgrade and simply had to install Cocoapods.

sudo gem install cocoapods

This hit me too. @martijnwalraven, is cocoapods now a requirement for IOS cordovoa integration?

1 Like

I am in the same situation, too. I have Meteor and iOS10.
When I hit “meteor run ios” it says;
✗ CocoaPods: CocoaPods was not found. Please install version 1.0.1 or greater from

I made a gem install cocoapods as @ashhimself suggested. Now it says;
The CocoaPods repo has not been synced yet, this will take a long time (approximately 500MB as of Sept 2016). Please run pod setup first to sync the repo.

The repo I download is more than 500MB in size…
But, it is now working.

Hi, I just installed cocoapods and it started working. But I am curious why it is now required to be able to build. I found this:

@martijnwalraven, @abernix: is cocoapods a requirement for iOS?

The requirements dictated by Meteor are directly pinned to those of Cordova. For example, if you had Cordova directly installed and ran cordova requirements ios – it would also dictate that CocoaPods are required (Meteor itself does not rely on CocoaPods).

I don’t recall exactly when it happened, but I believe it was in Cordova 6.0.0 and correlated to a similar XCode upgrade, but I do believe it is required to be installed in all circumstances.

As stated above, CocoaPods can be installed with gem install cocoapods (and when necessary, which is “usually”, using sudo as well).

1 Like

@abernix, thanks for the clarification.

osx 10.15.3 (19D76)

sudo gem install cocoapods
ERROR: While executing gem … (Gem::FilePermissionError)
You don’t have write permissions for the /usr/bin directory.