"meteor add typescript" command failing

me@debian:~/source/repos/meteor-app$ meteor add typescript
=> Errors while adding packages:

While selecting package versions:
error: Conflict: Constraint modules@0.14.0-beta182.17 is not satisfied by modules 0.13.0.
Constraints on package “modules”:

  • modules@~0.13.0 <- top level
  • modules@0.13.0 <- ecmascript 0.12.7
  • modules@0.13.0 <- ecmascript-runtime-client 0.8.0 <- ecmascript-runtime 0.7.0 <- babel-compiler 7.3.4
  • modules@0.12.0 <- promise 0.11.2 <- dynamic-import 0.5.1
  • modules@0.13.0 <- modern-browsers 0.1.4 <- babel-compiler 7.3.4
  • modules@0.12.0 <- ecmascript-runtime-server 0.7.1 <- ecmascript-runtime 0.7.0 <- babel-compiler 7.3.4
  • modules@0.13.0 <- babel-runtime 1.3.0
  • modules@0.13.0 <- dynamic-import 0.5.1
  • modules@0.13.0 <- fetch 0.1.1 <- dynamic-import 0.5.1
  • modules@0.13.0 <- inter-process-messaging 0.1.0 <- autoupdate 1.6.0 <- hot-code-push 1.0.4 <- meteor-base 1.4.0
  • modules@0.13.0 <- inter-process-messaging 0.1.0 <- dynamic-import 0.5.1
  • modules@0.12.0 <- es5-shim 4.8.0
  • modules@0.7.7 <- geojson-utils 1.0.10 <- minimongo 1.4.5 <- allow-deny 1.1.0 <- mongo 1.6.3
  • modules@0.7.7 <- geojson-utils 1.0.10 <- minimongo 1.4.5 <- mongo 1.6.3
  • modules@0.11.0 <- mongo-dev-server 1.1.0 <- mongo 1.6.3
  • modules@0.7.7 <- jquery 1.11.11
  • modules@0.9.0 <- npm-bcrypt 0.9.3 <- accounts-password 1.5.1
  • modules@0.12.0 <- http 1.4.2
  • modules@0.11.3 <- url 1.2.0 <- http 1.4.2
  • modules@0.14.0-beta182.17 <- typescript 3.5.2-beta182.17

Conflict: Constraint babel-runtime@1.4.0-beta182.17 is not satisfied by babel-runtime 1.3.0.
Constraints on package “babel-runtime”:

  • babel-runtime@~1.3.0 <- top level
  • babel-runtime@1.3.0 <- ecmascript 0.12.7
  • babel-runtime@1.4.0-beta182.17 <- typescript 3.5.2-beta182.17

Conflict: Constraint babel-compiler@7.4.0-beta182.17 is not satisfied by babel-compiler 7.3.4.
Constraints on package “babel-compiler”:

  • babel-compiler@~7.3.4 <- top level
  • babel-compiler@7.3.4 <- ecmascript 0.12.7
  • babel-compiler@7.3.4 <- minifier-js 2.4.1 <- standard-minifier-js 2.4.1
  • babel-compiler@7.3.4 <- standard-minifier-js 2.4.1
  • babel-compiler@7.4.0-beta182.17 <- typescript 3.5.2-beta182.17

anyone else have this issue?

I installed the meteor packages babel-compiler and babel runtime and tried to run meteor update, but no luck fixing the problem. I wanted to give this package a test drive :slight_smile:

Typescript is a pre-release package and has dependencies on package versions that are also pre-releases. To get the constraint solver to satisfied the deps, you’ll need to update your project to a beta release of Meteor.

Ohh ok. Thank you for that update. Is there a planned release date for this package or is that unknown for the time being?

As of this moment, I don’t believe there has been any official word… The GitHub milestone for the 1.8.2 release is currently at 61% and the the advancing pull request for the 1.8.2 branch can be found at the following…

2 Likes

and that guy is at burning man, smh … haha. Thanks for the info tho. It is much appreciated