Meteor app doesn't run on iPad, but runs on other iPhones


#1

I have an application that I am trying to submit to the iOS app store, and I am having a couple of issues with it.
The procedure that I am using to run the app is:
1.meteor build …/output --server https://xyz.com
2. ROOT_URL = https://xyz.com meteor run ios-device --mobile-server= https://xyz.com

Now I have gone through different issues and posts, and they mention that we do not need to use ROOT_URL if we are using the --mobile-server flag, but if I do otherwise, the app doesn’t work as expected. Also, once the app starts on the simulator/device it keeps on switching the root_url to the last used url, and I can’t seem to figure out why that might be. I have tried removing the previously installed app form the device and reinstalling it, and also tried removing the local meteor file, but the issue seems to persist.

Another problem is that, once I run the app using the above commands apart from the above one issue, it works on all the devices fine, except for iPad/iPad retina on which after showing the splash screen it just displays a blank white screen. When I debug the app using Safari it shows
"WebSocket connection to ‘wss://cattlekrush.com/sockjs/673/lysbzks3/websocket’ failed: Unexpected response code: 400". Any help on what the problem might be with the above mentioned issues, and hints for any possible solutions would be greatly appreciated.
Thanks.