Meteor App doesnt start in iOS simulator (xcode 6.2) - solved


#1

I’m trying to run the basic app that we get after running meteor create basic.

I have Xcode 6.2 and meteor 1.0.4.2

After running meteor run ios, I get BUILD SUCEEDED and the simulator starts.

Then the meteor app never shows up and Cordova console.log is empty.

Have you experienced this problem?


#2

It works fine :smile:. It was a problem with my setup.


#3

Could you give more details about the setup? I have the same problem. I have Xcode 5.2 and meteor 1.1.0.2. Whenever I run the meteor run ios, I got build succeeded but had no emulator poped up.
Thanks a lot.


#4

Try to run using the --verbose flag to see what’s actually happening under the hood.


#5

Hi Klanders,
I had the simulator open before running ‘meteor run ios’.

These steps work for me:

meteor run ios
Run the app from xcode
The simulator starts and runs the app


#6

I’m having a similar issue with Xcode 6.4. The simulator starts fine with meteor run ios but running the app after meteor build ../dist --mobile-server=http://foo.bar just builds successfully and sits there. The simulator just doesn’t open. There’s nothing in the system log or any warnings in Xcode.


#7

meteor build isn’t supposed to start the simulator. It generates a server deployment tarball and project directories for your mobile platforms so you can build the app for distribution.


#8

Thanks for the reply. Yep, I mean once it’s built and I run the Xcode project it wasn’t opening the Simulator. I also noticed that my app name had “Mac” as the deployment target instead of iOS and no warnings were visible when running. I ran meteor reset and tried building again and it works now.