Meteor app isnt loading in android emulator


#1

Meteor app isnt loading on to the emulator. I have been building for iOS for a few months and I finally got around to testing the android emulator. I assumed it would be as easy as the iOS install.

I added the sdk and the platform and tried to run it. It doesnt do anything and its not in the list of apps on the phone. I look on github and stackoverflow. One suggestion was to stop meteor and rerun it, but that doesn’t do anything. I ran the todo app on the emulator and it worked perfectly. Finally I tried to update the android sdk but that didn’t work either.

I cant figure out what to do next. There is no error that should be stopping this from working. Only error is saying that the “OAuth2 implementation doesn’t currently work.”

Has anyone else had a problem with this?


#2

Could you try this again with Meteor 1.2 RC (meteor update --release METEOR@1.2-rc.12)? There have been some major changes to the architecture of the Cordova integration, and hopefully that will help solve this issue. Note that part of these changes is the requirement to install your own Android SDK, so you may want to have a look at these instructions if you haven’t installed one already.


#3

I updated meteor and followed all those steps. No luck. I think it has to do with my code, I just dont have any errors. I can load the app on the emulator’s browser just can’t get the app to load.


#4

What specifically are the steps you take to run the app on the Android emulator, and what are the results? When you say you can load the app, do you mean it opens and you get a white screen? Have you tried remote debugging with Chrome to see if there are errors?


#5

I had an Icon file randomly in my .meteor folder and it messed up the load. Thanks for your help