Meteor-babel errors


#1

I am still on METEOR@1.6.1.3 and suddenly get the following error sporadically. Is there a version dependency between babel and meteor?

(STDERR) Compiling undefined with meteor-babel without a cache
(STDERR) [object Object]
(STDERR)     at Object.exports.compile (/Users/jhm/.meteor/packages/babel-compiler/.7.0.9.1yljg0v.on8yj++os+web.browser+web.cordova/npm/node_modules/meteor-babel/index.js:77:13)
...

#2

did you find any solution to this?

I think this is happening when meteor shell is opened.


#3

Yes, it does happen when shell is opened and any command is entered, and no, I have not found a solution


#4

Yeah, I’m having the same problem. Do we need to update/do something with babel?


#5

The same problem here, any suggestion?


#6

Same problem here, running latest meteor

Edit: solved my problem by wrapping my callback in Meteor.bindEnvironment


#7

Same on METEOR@1.7.0.4


#8

Same on Meteor 1.7.0.5 for me.

Steps:

  1. Run the Meteor server in one terminal
  2. Run meteor shell in another
  3. Call Email.send({to: "your-email@mail.com", from: "some-email@mail.com"})

This call is working, but this is output in the server terminal:

W20180821-13:38:19.053(2)? (STDERR) Compiling undefined with meteor-babel without a cache
W20180821-13:38:19.055(2)? (STDERR) [object Object]
W20180821-13:38:19.056(2)? (STDERR)     at Object.exports.compile (/Users/brookie/.meteor/packages/babel-compiler/.7.1.1.12ax3u2.09lgf++os+web.browser+web.browser.legacy+web.cordova/npm/node_modules/meteor-babel/index.js:77:13)
W20180821-13:38:19.056(2)? (STDERR)     at Object.compile (packages/babel-compiler.js:44:29)
W20180821-13:38:19.057(2)? (STDERR)     at Object.compileForShell (/Users/brookie/Projects/Code/lookback/lookback-site/app/.meteor/local/build/programs/server/packages/ecmascript.js:27:18)
W20180821-13:38:19.057(2)? (STDERR)     at REPLServer.wrappedDefaultEval [as eval] (/Users/brookie/Projects/Code/lookback/lookback-site/app/.meteor/local/build/programs/server/packages/shell-server.js:310:48)
W20180821-13:38:19.057(2)? (STDERR)     at REPLServer.onLine (repl.js:468:10)

#9

same here on METEOR@1.7.0.5
meteor server terminal

 (STDERR) Compiling undefined with meteor-babel without a cache
 (STDERR) [object Object]
 (STDERR)     at Object.exports.compile (/home/meteoruser/.meteor/packages/babel-compiler/.7.1.1.1mgy0v1.x0nq++os+web.browser+web.browser.legacy+web.cordova/npm/node_modules/meteor-babel/index.js:77:13)
 (STDERR)     at Object.compile (packages/babel-compiler.js:44:29)
 (STDERR)     at Object.compileForShell (packages/ecmascript/ecmascript.js:7:18)
 (STDERR)     at REPLServer.wrappedDefaultEval [as eval] (packages/shell-server/shell-server.js:236:48)
 (STDERR)     at REPLServer.onLine (repl.js:468:10)
 (STDERR)     at emitOne (events.js:121:20)
 (STDERR)     at REPLServer.emit (events.js:211:7)
 (STDERR)     at REPLServer.Interface._onLine (readline.js:280:10)
 (STDERR)     at REPLServer.Interface._line (readline.js:629:8)
 (STDERR)     at REPLServer.Interface._ttyWrite (readline.js:910:14)
 (STDERR)     at REPLServer.self._ttyWrite (repl.js:537:7)
 (STDERR)     at PassThrough.onkeypress (readline.js:158:10)
 (STDERR)     at emitTwo (events.js:126:13)
 (STDERR)     at PassThrough.emit (events.js:214:7)
 (STDERR)     at emitKeys (internal/readline.js:420:14)
 (STDERR)     at emitKeys.next (<anonymous>)
 (STDERR)     at PassThrough.onData (readline.js:1010:36)
 (STDERR)     at emitOne (events.js:116:13)
 (STDERR)     at PassThrough.emit (events.js:211:7)
 (STDERR)     at addChunk (_stream_readable.js:263:12)
 (STDERR)     at readableAddChunk (_stream_readable.js:250:11)
 (STDERR)     at PassThrough.Readable.push (_stream_readable.js:208:10)

also noticed another error (maybe not related but i see no bug)
meteor shell terminal

Promise {
  <pending>,
  domain: 
   Domain {
     domain: null,
     _events: { error: [Function: debugDomainError] },
     _eventsCount: 1,
     _maxListeners: undefined,
     members: [] } }

#10

I have the same problem.


#11

Was this solved? I’m having this issue too.


#12

Still having this issue


#13

Same here, 1.7.1-beta.15.