Meteor Clear Cache


#1

So I am requesting a meteor clear cache command. Or clarification on any possible under the hood caching saving mechanism that might have caused this:

I ran into a strange error today that didn’t fix itself until I reworked a JSX file to be a different name.

I started by reading the new official meteor react tutorial and copy pasted App.jsx and Task.jsx into my project as the first files in the project.

I thought I hit a keyword when I used Transactions = new Meteor.Collection('transactions') and ran into a insert is already defined error.

But when I rewrote the Mongo.Collection code to be Payments centric, I was still getting the same error, as if something was still cached. I found a stackoverflow question about user/insert that validated that this was a keyword issue.

I searched for a meteor clear cache command but found nothing in meteor --help to help flush any old code.

This blew my hunch of ‘its a keyword’ out of the water. That is until I changed Task.jsx to be LineItem.jsx and all of a sudden the error disappeared.

Here is the original help request on Stackoverflow. As you can see it didn’t take me long to validate that it was some under the hood meteor magic, and that I needed to flush the system. Maybe I am missing something, but the only command I saw was to reset the database.

Thanks in Advance!

And any input, explanation of what happened, would be super appreciated. Magic vs Competence.

-Robert Baindourov


#2

I’ve run into this recently as well; it’s definitely a real bug.


#3

Thanks for confirming.

So perhaps a meteor --rebuild option or meteor rebuild command is not a bad idea for those of us who experience something similar or are just in doubt. Until the true nature of the bug is diagnosed and addressed.

Should I open an issue on github?

Thanks Again!


#4

Yeah, we have meteor reset but that also clears the database. I think it could be good to open a request for a command that resets all temporary build stuff, but leaves the DB intact.


#5

Okay!

Thanks Sashko!

PS.

I don’t know if you prefer to be called Alexander. My uncle does.


#6

Nope, I list Sashko everywhere intentionally, that’s a good name for me!


#7

Do we have yet a command to reset temporary cache?


#8

This needs a bump. I’m having this issue today.

Edit: never mind, this was a CDN caching issue.