Meteor command does not work with angular-meteor base - SOLVED


#1

I am trying to follow the angular 2 socially tutorial

The starting point for which is this repo.

Unfortunately I am having a few problems following along.

Firstly, the tutorial says to use this command
meteor create --example angular2-boilerplate socially
But for me this just prompts me to clone the github repo, which I do.

I then do a meteor npm install, which does it it’s thing.

However when I then try to run the app, meteor does nothing, it just sits there with the cursor blinking.

So, what I tried next was to create an empty meteor project ( meteor create socially)
Then copy across all content from the cloned repo - with exception of the .meteor folder.

This works, in that meteor now starts the app. However it does not have the correct packages for angular (obviously).
So I am now trying to add them in.

So far, I have done the following:

meteor remove ecmascript
meteor update pbastowski:angular-babel
meteor remove blaze-html-templates
meteor add angular-templates

But, whilst the application still runs, it’s does not appear to be building the assets correctly.
The angular app does not load and if I look in dev tools, I see only the packages folder under the app.
The client folder and files are not there.

Any help much appreciated

UPDATE: I cloned the repo again. And these time ran meteor from a native command window and after waiting for it to download and install meteor (??) it now works.