Meteor: command not found MAC

Hi Community, I am very new here and try:
to install curl | sh
and the the first tutorial:

yolo123$ meteor create simple-todos
-bash: meteor: command not found

I am using mac.

Many thanks!

Did you install as you or with sudo?

Hi robfallows, i tried both. :-/

You need to make sure you don’t use the root account to install, or you will likely get issues later.

As you have used the root account, you should delete the installation artefacts which were created by root (you will obviously need to be root to do this).

rm -rf ~root/.meteor
rf /usr/local/bin/meteor

Then, reinstall under your account, with curl | sh. You will be prompted for your sudo password as part of the installation.

1 Like

Hi robfallows,

I typed: sudo rm -rf ~root/.meteor and sudo rf /usr/local/bin/meteor
result: -bash: rf: command not found

so i tried rm -r /usr/local/bin/meteor
-bash: cd: /usr/local/bin/meteor: No such file or directory --> i think it works :slight_smile:

Yes, it works!! Many Thanks rob!!

(btw. i reinstall xcode again, dont know if it is important)

1 Like

Yeah - I meant rm, but mistyped. :confused: