Meteor cordova build fails with 1.3


#1

I’d updated to 1.3 and tried to execute meteor run android-device --settings settings.json --verbose --production --mobile-server http://...

I got the following message:

   While running Cordova app for platform Android with options --device:
   Error: Command failed:
   C:\Projects\web\sauron\webinterface\.meteor\local\cordova-build\platforms\android\cordova\run --device --device
   FAILURE: Build failed with an exception.

   * What went wrong:
   A problem occurred configuring root project 'android'.
   > Could not resolve all dependencies for configuration ':_armv7DebugCompile'.
   > Could not find com.android.support:support-v4:23.2.0.
   Searched in the following locations:
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.pom
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.jar

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.pom

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.jar
   Required by:
   :android:unspecified > com.android.support:support-v13:23.1.1
   > Could not find com.android.support:support-v4:23.2.0.
   Searched in the following locations:
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.pom
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.jar

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.pom

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.jar
   Required by:
   :android:unspecified > com.facebook.android:facebook-android-sdk:4.10.1
   > Could not find com.android.support:cardview-v7:23.2.0.
   Searched in the following locations:
   https://repo1.maven.org/maven2/com/android/support/cardview-v7/23.2.0/cardview-v7-23.2.0.pom
   https://repo1.maven.org/maven2/com/android/support/cardview-v7/23.2.0/cardview-v7-23.2.0.jar

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/cardview-v7/23.2.0/cardview-v
7-23.2.0.pom

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/cardview-v7/23.2.0/cardview-v
7-23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/cardview-v7/23.2.0/card
view-v7-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/cardview-v7/23.2.0/card
view-v7-23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/cardview-v7/23.2.0/cardv
iew-v7-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/cardview-v7/23.2.0/cardv
iew-v7-23.2.0.jar
   Required by:
   :android:unspecified > com.facebook.android:facebook-android-sdk:4.10.1
   > Could not find com.android.support:support-v4:23.2.0.
   Searched in the following locations:
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.pom
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.jar

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.pom

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.jar
   Required by:
   :android:unspecified > org.xwalk:xwalk_core_library:17.46.448.10
   > Could not find com.android.support:support-v4:23.2.0.
   Searched in the following locations:
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.pom
   https://repo1.maven.org/maven2/com/android/support/support-v4/23.2.0/support-v4-23.2.0.jar

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.pom

   https://download.01.org/crosswalk/releases/crosswalk/android/maven2/com/android/support/support-v4/23.2.0/support-v4-
23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/android/m2repository/com/android/support/support-v4/23.2.0/suppo
rt-v4-23.2.0.jar

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.pom

   file:/C:/Users/Marc/AppData/Local/Android/sdk/extras/google/m2repository/com/android/support/support-v4/23.2.0/suppor
t-v4-23.2.0.jar
   Required by:
   :android:unspecified > com.google.android.gms:play-services-ads:8.4.0 >
   com.google.android.gms:play-services-basement:8.4.0

   * Try:
   Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log
   output.
   at ChildProcess.exitCallback (C:\tools\utils\processes.js:151:23)
   at ChildProcess.emit (events.js:98:17)
   at Process.ChildProcess._handle.onexit (child_process.js:820:12)

C:\Users\Marc\AppData\Local\.meteor\packages\less\2.5.6\plugin.compileLessBatch.os\npm\node_modules\meteor\promise\node_
modules\meteor\promise\node_modules\meteor-promise\promise_server.js:116
      throw error;
            ^
ExitWithCode:1

#2

Installing Android Support Repository and Google Repository in the Android SDK manager fixed this.


#3

It seems like you may not have the right version of the Android Support Library installed. Have you tried installing it using the Android SDK Manager?


#4

Sorry, missed your response!


#5

I have still same issue when add crosswalk plugin I ask it here:


Can someone help me?