Meteor crashing: "Can't find npm module 'double-ended-queue'"

Hello there dear Meteor community!

Just now, out of nowhere my app comes up with an error. The app was running fine and i was just changing some templates in the view and js file, nothing fancy at all. And during a ctrl+s the app just crashes. I reverted the recent changes which “caused the crash” (i have no idea what caused the crash). But it still doesnt work.

I am 100% sure i havent changed anything fancy, just some html / javascript which i then ctrl-z’d. The app worked 5 minutes ago.

Any help would be greatly appreciated.

W20150408-11:56:50.347(2)? (STDERR)     at Module._compile (module.js:456:26)
W20150408-11:56:52.101(2)? (STDERR)           
W20150408-11:56:52.102(2)? (STDERR)     throw err;
W20150408-11:56:52.102(2)? (STDERR) module.js:340
W20150408-11:56:52.102(2)? (STDERR)           ^
W20150408-11:56:52.103(2)? (STDERR) Error: Cannot find module 'fibers'
W20150408-11:56:52.103(2)? (STDERR)     at Function.Module._resolveFilename (module.js:338:15)
W20150408-11:56:52.103(2)? (STDERR)     at Function.Module._load (module.js:280:25)
W20150408-11:56:52.104(2)? (STDERR)     at Module.require (module.js:364:17)
W20150408-11:56:52.104(2)? (STDERR)     at require (module.js:380:17)
W20150408-11:56:52.104(2)? (STDERR)     at Object.<anonymous> (/Users/**hidden**/testapp/.meteor/local/build/programs/server/boot.js:1:75)
W20150408-11:56:52.104(2)? (STDERR)     at Module._compile (module.js:456:26)
W20150408-11:56:52.104(2)? (STDERR)     at Object.Module._extensions..js (module.js:474:10)
W20150408-11:56:52.104(2)? (STDERR)     at Module.load (module.js:356:32)
W20150408-11:56:52.104(2)? (STDERR)     at Function.Module._load (module.js:312:12)
W20150408-11:56:52.104(2)? (STDERR)     at Module.require (module.js:364:17)

I just noticed that im getting the same error when i start other meteor applications as well.

I would greatly appreciate some insight, im eager to start using meteor again :smile:


I ran an “meteor update” and now i’ve got another error message…

W20150408-18:38:01.982(2)? (STDERR)           
W20150408-18:38:01.983(2)? (STDERR) /Users/myname/simple-todos/.meteor/local/build/programs/server/boot.js:263
W20150408-18:38:01.983(2)? (STDERR) }).run();
W20150408-18:38:01.983(2)? (STDERR)    ^
W20150408-18:38:01.998(2)? (STDERR) Error: Can't find npm module 'double-ended-queue'. Did you forget to call 'Npm.depends' in package.js within the 'meteor' package?
W20150408-18:38:01.998(2)? (STDERR)     at Object.Npm.require (/Users/myname/simple-todos/.meteor/local/build/programs/server/boot.js:155:17)
W20150408-18:38:01.998(2)? (STDERR)     at Meteor.startup (packages/meteor/fiber_helpers.js:17:1)
W20150408-18:38:01.998(2)? (STDERR)     at /Users/myname/simple-todos/.meteor/local/build/programs/server/packages/meteor.js:808:4
W20150408-18:38:01.998(2)? (STDERR)     at /Users/myname/simple-todos/.meteor/local/build/programs/server/packages/meteor.js:1240:3
W20150408-18:38:01.998(2)? (STDERR)     at /Users/myname/simple-todos/.meteor/local/build/programs/server/boot.js:222:10
W20150408-18:38:01.998(2)? (STDERR)     at Array.forEach (native)
W20150408-18:38:01.998(2)? (STDERR)     at Function._.each._.forEach (/Users/myname/.meteor/packages/meteor-tool/.1.1.3.uqboz++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/server-lib/node_modules/underscore/underscore.js:79:11)
W20150408-18:38:01.999(2)? (STDERR)     at /Users/myname/simple-todos/.meteor/local/build/programs/server/boot.js:117:5

Update: This also happens on a “fresh” app

meteor create myapp
cd myapp

same error, app does not start.

Since its been a day since i created the thread and i’m eager to start coding again, i’m giving this thread a bump!

Are you on Windows, Linux… you’re using OSX?

edit. err not Windows, sorry just looked at the file paths.
Also can see its OSX.

Which means you’re dev’ing locally.

given how this is impacting a fresh project you’re just creating I am not sure what the issue is… very strange.

Thank you for the response. Yes im using OSX. 10.10.3, the error occured on 10.10.2 though.

What would you recommend me doing?

What comes up when you check meteor logs, is it largely the same as what you have above?

maybe even try meteor debug
I am just throwing out ideas here. I am no expert and haven’t had the same issue, sorry :frowning:

I cant seem to figure out how to use metoer logs :pensive:

:dizzy_face: oh sorry, my mistake.
It is for getting logs of published apps on

meteor logs site

Retrieves the server logs for the named Meteor application.
Meteor redirects the output of console.log() in your server code into a logging server. meteor logs displays those logs. In client code, the output of console.log() is available in your web browser’s inspector, just like any other client-side JavaScript.

Oh, my app is not published. I’ve worked with meteor for like 4 days, i’m just developing small stuff and having fun, and this error appears out of nowhere, ruining the fun :frowning:

Yeah I am sure it is.
Hopefully someone with more experience drops in and helps out.

Solved it by removing and re-installing Meteor.

sudo rm /usr/local/bin/meteor
rm -rf ~/.meteor

sudo curl | /bin/sh

Would have been nice to figure this out 24 hours ago, whatever, i’m a beginner. Would be cool with some help next time though.

Case closed

Had the same error. Meteor reset solved it for me.

I keep getting this problem as well, this is what I know so far

  • Once the problem happens, I can’t build any meteor project (not after removing .meteor/local, not even new projects I just created), which leads me to believe something is corrupt on the main ~/.meteor/ folder, and not on the project’s local .meteor folder.
  • I’ve had this when I tried to move from Windows to Linux (2 work stations, synchronized with Dropbox), whereas the only folder that’s not under git (and thus I can’t tell if there were changes in said folder) is .meteor/local. it might be possible that dropbox is corrupting something in the local folder, which then corrupts something on the root ~/.meteor folder (?)

The only way I could find to fix this is to remove my main ~/.meteor/ directly and reinstall meteor.

It seems today I have joined the club :frowning:

Several times today I’ve seen similar errors with no discernable cause. The module that can’t be found varies. All meteor projects are dead with the same missing module error.

I’m also on OSX. Also projects are in a Dropbox folder, though not synchronized anywhere else at the moment.

So far the only workaround I’ve found is to reinstall meteor. I’d really like to have a better solution to this.

same just happened to me too. i did a couple of upgrades at about the same time so i’m not exactly sure what triggered it.

(pong 588) $ meteor --version
(pong 589) $ uname -a
Darwin pong.local 14.5.0 Darwin Kernel Version 14.5.0: Wed Jul 29 02:26:53 PDT 2015;
root:xnu-2782.40.9~1/RELEASE_X86_64 x86_64

same symptoms as listed above. running:

$ meteor create something
$ cd something
$ meteor
[[[[[ ~/something]]]]]                  
=> Started proxy.                             
=> Started MongoDB.                           
W20150920-06:44:44.521(-7)? (STDERR) /Users/kjolley/something/.meteor/local/build/programs/server/boot.js:263
W20150920-06:44:44.521(-7)? (STDERR) }).run();
W20150920-06:44:44.521(-7)? (STDERR)    ^     
W20150920-06:44:44.522(-7)? (STDERR) Error: Can't find npm module 'double-ended-queue'. Did you forget to call 'Npm.depends' in package.js within the 'meteor' package?

what looked fishy to me was meteor-tool showed 1.1.4 in one command and 1.1.3 in another.

$ rm -rf ~/.meteor
$ meteor

and the problem went away

You can try “Meteor reset” in the terminal. This resets your database but nothing else. I think this solved my problem. I havent gotten it for a while

If anyone else comes across this, I solved it on my Mac (El Capitan) by:

  1. Reinstalling Meteor from
  2. cd to my app directory
  3. type: meteor rebuild
  4. type: meteor reset
  5. Reinstall any packages you’ve added
  6. Run the app via meteor

Now works fine for me! :sunglasses: