Meteor crashing on start-up


#1

Since my unsuccessful attempt to migrate one of my apps to Meteor 1.2, I am experiencing a very weird behaviour. Every time I try to start-up an app (even an untouched one), I’m getting this error message:

0151019-10:16:17.046(2)? (STDERR)           
W20151019-10:16:17.047(2)? (STDERR) module.js:340
W20151019-10:16:17.047(2)? (STDERR)     throw err;
W20151019-10:16:17.047(2)? (STDERR)           ^
W20151019-10:16:17.047(2)? (STDERR) Error: Cannot find module 'fibers'
W20151019-10:16:17.047(2)? (STDERR)     at Function.Module._resolveFilename (module.js:338:15)
W20151019-10:16:17.047(2)? (STDERR)     at Function.Module._load (module.js:280:25)
W20151019-10:16:17.048(2)? (STDERR)     at Module.require (module.js:364:17)
W20151019-10:16:17.048(2)? (STDERR)     at require (module.js:380:17)
W20151019-10:16:17.048(2)? (STDERR)     at Object.<anonymous> (/Users/waldgeist/Documents/Development/htdocs/makuzu/webapp/.meteor/local/build/programs/server/boot.js:1:75)
W20151019-10:16:17.048(2)? (STDERR)     at Module._compile (module.js:456:26)
W20151019-10:16:17.048(2)? (STDERR)     at Object.Module._extensions..js (module.js:474:10)
W20151019-10:16:17.048(2)? (STDERR)     at Module.load (module.js:356:32)
W20151019-10:16:17.048(2)? (STDERR)     at Function.Module._load (module.js:312:12)
W20151019-10:16:17.048(2)? (STDERR)     at Module.require (module.js:364:17)

I could solve this problem yesterday by re-installing Meteor completely. But after starting my Mac in the morning today, this problem re-appeared. None of my apps is working any more. Any ideas what could cause this problem?


[Solved] Fastclick package breaks app
#2

I think I got this in the past and solved it by creating a brand new app with meteor create, then copying all my files over to the new folder (don’t copy the .meteor folder, except the packages file).


#3

I had this before (but can’t remember now when). I think what I did was to do an update or reinstall one of the following:
node (to a higher version)
npm
meteor

or remove .meteor in your ~/ folder and do a meteor update…


#4

@Steve: As all apps are affected at the same time (independent of the folder they are stored in), this did not help. The only solution was to uninstall Meteor completely and re-install it. I did this yesterday, but was faced with the very same problem again today morning. I’ve repeated the uninstall-install process. Now it works again, but I don’t know for how long… This was the main reason why I was reaching out for help - to get a clue what the root cause might be.


#5

@tjmonsi: I tried to re-install node and npm (and also an npm update -g), but this did not help. The only solution I found was to uninstall Meteor and re-install it. But it happened again today…


#6

Check your .meteor/versions and .meteor/packages. I’ve seen instances where new package data gets left behind and confuses the build chain and where meteor-platform (needed for pre-1.2) doesn’t make its way back in.


#7

The problem occurs in every app, even in the untouched ones. So I doubt it is related to the package and versions files. But I will check if the error happens again (already re-installed Meteor and now everything is working - until next time).


#8

Huh… That’s kinda weird. It seems it reverted or something. Even when you did a meteor update on each of the local meteor apps?


#9

I couldn’t do an update, since I want these apps to stay on Meteor 1.1. But I don’t think the problem is related to that, because the apps were untouched and were working perfectly the day before. The problem occurred after I added an Meteor 1.2 app to the scene and experimented with it. In this app, I first go this ‘fiber error’. And after this, all other (1.1) apps were affected, too.


#10

It seems you have a lot of issues with your Meteor install. I am not sure where it lies but I think there are lots and lots of people who just keep upgrading and have almost no issues. Also with developers who take projects from Github installs just go well. Issues only happen when they try to be smart and install or work in different ways than just the default install.

Are you sure you just have a normal installation and the only difference is that you don’t update?

What version of software is on the Mac?
Do you use brew to install software?


#11

@lucfranken: Yep, maybe it’s just me, I don’t know. My configuration is pretty standard, I used the Node.js and Meteor installers, that’s it. I absolutely have no clue at all what made the tools break. After re-installing Meteor twice (and staying on 1.1), everything is working again so far. But I’m hesitating to try 1.2 again, to be honest, after this experience.


#12

Do you have answers to my 2 questions?


#13

Regarding your questions:

Node is on 4.2.1, Meteor on the latest available (just re-installed it recently).
I’m using brew, but not for Meteor-related stuff.


#14

There’s your problem.


#15

Don’t install things by hand, and if, only use brew on Mac.

 curl https://install.meteor.com/ | sh

That thing should do most of the trick. If you start messing around with configs things go wrong. Certainly at upgrades (as you experienced). Sometimes, I took a new laptop, you need to install something by hand but you will get a warning on it.


#16

That’s exactly how I installed it :smile:


#17

Without having to do any other commands? I cannot really believe that it worked for you totally out of the box. Or off course your system has already installed other tools. I mean from a clean install.


#18

AFAIR, I installed Node.js via its installer, and I installed Meteor using the curl command. Of course, I also have a lot of other stuff on that PC, like brew, Cordova and Xcode. But for Meteor, I think installing Node.js and Meteor was enough.