Meteor creating a dev_bundle folder inside .meteor/dev_bundle


#1

Ever since today I’m not sure what’s going on, but when I run meteor it creates a folder inside .meteor/dev_bundle.

What’s the purpose of this folder, it weights quite a bit as well and I would like to ignore it via git if necessary.


#2

It’s a symbolic link to the dev_bundle associated with the release specified by .meteor/release. This helps tools like meteor npm and meteor node find the right versions of npm and node to run for your app (see this issue for an example of why that’s important). Note: on Windows, .meteor/dev_bundle may be a file containing an absolute path, instead of a symbolic link to that path.

In other words, .meteor/dev_bundle is very much intentional, it’s not an actual directory (though it may look like one), and it should already be ignored by your .meteor/.gitignore file, thanks to this code.


Add .meteor/dev_bundle to git or not?
#3

nope, without adding it to the gitignore file, mine just went straight up in github


#4

yeah I had to manually add it


#5

Had to manual add it as well, this might work in a new meteor app but for upgraded ones it doesn’t seem to be working


#6

I did NOT update my meteor version (1.2.1) and this directory just appeared. Now it is breaking my tests with this error.

Error: EEXIST, symlink '/Users/lilinader/.meteor/packages/meteor-tool/.1.3.4_4.1xkdjtd++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle’
at Object.Future.wait (/Users/lilinader/.meteor/packages/velocity_meteor-tool/.1.1.10_2.1rc42z9++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/fibers/future.js:398:15)
at /tools/fs/files.js:1331:28
at Object.wrapper (/tools/fs/files.js:1334:20)
at /tools/fs/files.js:461:13
at Array.forEach (native)
at Function..each..forEach (/Users/lilinader/.meteor/packages/velocity_meteor-tool/.1.1.10_2.1rc42z9++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/underscore/underscore.js:79:11)
at Object.files.cp_r (/tools/fs/files.js:446:5)
at Command.doRunCommand [as func] (/tools/cli/commands.js:315:11)
at /tools/cli/main.js:1378:23


#8

I am having the same error as @lnader.

My meteor version is 1.2.1. Velocity is not working any more.


#9

are you using mupx?

Because, this dev_bundle symlink is only appearing in the projects where I used mupx for deployment.


#10

No, I’m not using mupx. The only way I was able to get around this was to delete the .meteor/local and .meteor/dev_bundle before running the test (every time). You have to do this before meteor --test. Very annoying!


#11

I confirm, it’s not related to mupx. For me sometimes, you don’t have to delete those two folders. Sometimes running tests fails, sometimes it works. But, in case of failure deleting those two folders solve the problem.


#12

After I updating to Meteor 1.3.5.1, it won’t upload to git now.