Meteor debug not working

I’m trying to debug my project, but having a lot of trouble. I first tried “meteor debug” which prints out the following:

=> Started proxy.
=> Started MongoDB.
Starting your app |
Your application is now paused and ready for debugging!

To debug the server process using a graphical debugging interface,
visit this URL in your web browser:

However, navigating to that page produces “No data received” in Chrome, and “the server unexpectedly dropped the connection” in Safari. I read somewhere that node-inspector might be required, even though I hadn’t seen it mentioned any where else, but installing that doesn’t help.

I’ve also seen a few people recommend WebStorm. I use PyCharm already and installed the Meteor plugin for it, added the appropriate configuration for it in PyCharm and started a debug session, but it’s not stopping at any of the break points or anything debug related. Is this an issue with Meteor 1.2, or am I missing something that’s not documented anywhere?


This worked for me:

Turns out this is an issue with Meteor 1.2 and the ecmascript / babel transpiling. Using the WebStorm 11 EAP it works, as they have fixed this issue:

The Meteor plugin that exists for PyCharm and other JetBrains IDEs is still using the WebStorm 10 version, which does not include the transpiling fixes. I can verify that using WebStorm 11 EAP works, and now we all just have to wait for 11 to be made generally available, at which point JetBrains will update the Meteor plugin for the other IDEs.

I still can’t get “meteor debug” to work though. Not sure if it’s related to transpiling, but now that I’ve got debugging working with WebStorm 11 EAP, I’m all set.

1 Like

“meteor debug” NOT working for me
my project scripts are missing from chrome tools scripts panel
Below is the only script I can see.
I am on windows 10 and have just done a meteor update to no avail.
and node-inspector works just fine for me on plain node.js projects.

What am I missing?

(function (exports, require, module, __filename, __dirname) { 
// The debugger pauses here when you run `meteor debug`, because this is 
// the very first code to be executed by the server process. If you have 
// not already added any `debugger` statements to your code, feel free to 
// do so now, wait for the server to restart, then reload this page and 
// click the |▶ button to continue.
process.argv.splice(2, 0, 'program.json');
process.chdir(require('path').join(__dirname, 'programs', 'server'));

I had the same problem. When you see that file have to press play to “start” the server. Then you have to open up your website in a browser window to trigger the request. Then, if you open up the folder structure to view files you’ll see a new “folder” in the tree called “app” with your project files

I’ve got opposite problem with node.js last version . I’ve got some break about half a year in meteor development and I certainly remember that the message about pausing had place with meteor debug. Now I haven’t. Is it right?

Certainly meteor 1.5.2 for windows has bug:
“meteor debug” and “meteor run --debug-port” commands don’t really get debugger listening on port.
Only setting NODE_OPTIONS=–debug with meteor run involves debugger.
I’ve got console message “Debugger listening on [::]:5858” and after that I can attach to process.