Meteor debug pausing on every uncaught exception during startup, can't disable


Hi all,

When I connect to the debug interface, I have to press “continue” many, many times because it breaks every on uncaught “Error: ENOENT, no such file or directory” exception. These exceptions are harmless and expected since Meteor runs normally in non-debug mode.

I can’t figure out how to disable “break on uncaught exceptions” - does anyone know how?

I don’t know if this is a new problem. Previously, I would change the “debug-brk” to “debug” and then connect after startup, but that doesn’t seem to work since my last Meteor upgrade.

Any help or pointers would be appreciated.



Uncheck “stop on uncaught exceptions” tick in your debugger


I’m talking about server-side debugging and I think you’re talking about client-side?

The Node Inspector debugger doesn’t have that blue pause button.

Sorry, can’t send screenshot, or even links to such. I get the error: “Sorry, new users can’t put images in posts.”


I mean, it is the same in node-inspector. They just use an older version of the dev tools. See bottom left corner


Argh! Thank you! Well spotted!