Meteor docker max_user_watches


#1

I am experimenting with running meteor inside docker container, and with the new build I got this error:

It looks like a simple tweak to your system’s configuration will make many
tools (including this Meteor command) more efficient. To learn more, see
https://github.com/meteor/meteor/wiki/File-Change-Watcher-Efficiency

I then followed the link and attempt to make the change and then got this error

sysctl: setting key “fs.inotify.max_user_watches”: Read-only file system

Then I deleted the container and run it in --privileged mode and run the command again and this time it works.

The question is: Is this the recommended method? must containers run in --privileged mode to be able run meteor efficiently? Or is there a workaround?