Meteor doesn't start after latest upgrade


#1

Hi,

I am still going through the tutorials. I upgraded to Meteor 1.4.1.1 today and I am constantly getting following error
`ca-STivare-mac::~/cbmax $meteor update --patch
/Users/stivare/.meteor/packages/meteor-tool/.1.4.1_1.1h0re2h++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/dev_bundle/lib/node_modules/meteor-promise/promise_server.js:165
throw error;
^

Error: ENOENT: no such file or directory, open '/private/var/folders/7j/q5q07jkj0qs38k218yf6bnl8y6wpw0/T/mt-c85hvj/os.json’
at Error (native)
ca-STivare-mac::~/cbmax $
`

I tried uninstalled meteor completely and reinstalled it. Still getting the same error.

Any help will be greatly appreciated.

Thanks
Sudheer


#2

Have you tried meteor reset? I’m not sure what’s in that /private/var folder


#3

Happens to me too. I try meteor update but I get the same error


#4

After reinstalling meteor with:

curl https://install.meteor.com/ | sh

It works again, thanks anyway.


#5

I have the same problem when I try to update meteor (from 1.4.1 to 1.4.1.1), reinstalling meteor with curl https://install.meteor.com/ | sh and meteor reset doesn’t work.

Any suggestions? I’m stuck :sob:.

Thanks.


#6

Did you install meteor outside of your project folder?

In your project folder did you try meteor update --patch ?

The reinstall meteor works for me in mac osx


#7

Also, you can try:

curl https://install.meteor.com/ | sh // outside the project

meteor update --release 1.4.1.1 // inside the project

(taked from here: https://github.com/meteor/meteor/issues/7476)


#8

I have restarted my mac, with all windows close, I have launched with terminal from the project folder curl https://install.meteor.com/ | sh and meteor reset.

Now it works fine.

Thanks.


#9

Thanks guys for the replies. I uninstalled the application once again and installed 1.4.1 using release=1.4.1 argument to the curl command and that seems to work.

The latest upgrade patch still fails. But no worries. I am still learning so not concerned too much about the latest version.

Thanks
Sudheer


#10

Whats they syntax for the curl with release=1.4.1


#11
curl https://install.meteor.com/?release=1.4.1 | sh

Sorry about the late response.
Sudheer


#12

I was getting same errors.

meteor update --release 1.4.1.1 // inside the project

Worked for me. Thanks!