Meteor doesn't work in Windows 10

I downloaded the Meteor’s official Download from here: [Meteor 1.2.1][1]
and the installer is just 1.2mb

Now, after running it: Nothing happens. No permission. Nothing. This page is shown:

[![THis happens in 0.5s.][2]][2]

And then when I hit Skip this step, this is shown:

[![And it doesn’t work.][3]][3]

Even after restaring, there is no .meteor folder in AppData\Local directory, and Meteor command is still not recognised.

Also, I think, how can a 1.2mbinstall something like Meteor which is like 53mb when installed via curl on OSX or Linux.

Are the Meteor fooling windows? I dont know why the installer doesn’t work. The point is: How can it?

The installer doesn’t have to be the full download, since it can only bundle the bare minimum and download the rest just as on MacOS/Unix…

As for why it’s not installing - no idea, sorry

MDG? Why is this not working?

i install meteor in windows 10, and i don’t have a problem

What happens after the installer finishes? Does the meteor command get available just after installation?

Sorry for that. We are aware that our installer has issues at times on some machines.

Here are alternative installation instructions that work without using the installer. You still get all the features of Meteor such as updating to new releases, etc.