Meteor frequently restart when deploy with Phusion Passenger

Hello, is there anyone has experienced this problem before?

When check the uptime app i see the period never get longer than a day.

When i check the status by using command: passenger-status, this message show up right before app restart.

I have no idea what happened with meteor or phusion passenger.

age/Cor/CoreMain.cpp:1147 ]: Checking whether to disconnect long-running connections for process 4051, application /var/www/liveapp/bundle (production)
[ N 2020-06-14 23:51:27.0548 5222/T1 age/Wat/WatchdogMain.cpp:1373 ]: Starting Passenger watchdog...
[ N 2020-06-14 23:51:27.0736 5225/T1 age/Cor/CoreMain.cpp:1340 ]: Starting Passenger core...

How are you running passenger? Heroku, AWS, self manage?

1 Like

It’s self manage, i’m running passenger on Digital Ocean, server specs: 4GB ram, 2vCPUs.

Do you have any monitoring tools in place?

You could try setting passenger_pool_idle_time to 0

I didn’t use any monitoring tool, i have set pool_idle_time to 0 but don’t know how to check if it work or not.

How is your passenger configured (nginx, apache, etc)? Can you post the config

I used passenger standalone version, i don’t know where could i see the config?

How do you run passenger with its options? Command line or passengerFile.json? If you use the json file you can do

http {
    passenger_pool_idle_time 0;

I use Passengerfile.json, i tried to change the max_pool_size value by add the config max_pool_size without passenger prefix, i wonder if it’s the same with pool_idle_time config?

I would try with what I posted above, you can add your max_pool_size into that. These are two different options that do different things.

How could i check if the config will be applied or not?
Update: The app still suddenly restart after i do some specific task like export a csv file:
And it’s show this message before started again:

Checking whether to disconnect long-running connections for process 4051, application /var/www/liveapp/bundle (production)