Meteor installation failed, unable to resolve host

I am using ubuntu 14.04 and it’s strange that I can’t successfully install. Are there any alternaives to installation method or any solution to this unable to resolve host problem? Thanks in advance. I really want to try meteor 1.3.

 % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  6672    0  6672    0     0    615      0 --:--:--  0:00:10 --:--:--  1535
Downloading Meteor distribution

curl: (6) Could not resolve host:

gzip: stdin: unexpected end of file
tar: Child returned status 1
tar: Error is not recoverable: exiting now
Installation failed.

Hi teruun,

Try reinstalling again. It appears that it is due to your installation being aborted due to an internet connectivity problem (or) because’s server DNS address could not be found…

Try again after sometime. It should work…

Thank you jbenga,

I will try reinstall it everyday, but I’m afraid it will take too much time, hope it’s not after the publication of meteor1.4

I think it’s because I’m in china and the great firewall did something to my connection. It’s been two days and I can’t find a solution.

I’m using a shadowsocks vpn and to make it work on my terminal, installed proxychains. But still doesn’t work. It will be very nice to tell me if you have any other ways that I can try.

Maybe I should download the sourcecode of meteor and run it by myself. But, everything is much harder in china and maybe I’ll get stuck in some other package installation problem.

It worked! haha
Thanks again

1 Like