Meteor iron-router appends dot (.) at the end of routes

I have created a project with Meteor 1.6 and it works fine but I noticed the router always append (.) dot at the end which makes the not to find the route path. An example is http://localhost:3000/. I have tried looking into what could be the problem by trimming the path before running the route bt it does not run the onBeforeAction trigger. Please this same project worked well with Meteor-1.2.1.

Router.route('/', {
    name: 'home',
    onBeforeAction: function () {
    	if (Router.current().route.path() != '/') {

The trim function

Template.registerHelper('TrimEndOfString', function (endofstring) {
  alert( endofstring.slice(0, -2));

When I view the browser console I fond this error. How do I resolve this?

Error log

Error: Cannot find module 'mongo-object'                                          modules-runtime.js:231:12
TypeError: Package['aldeed:autoform'] is undefined[Learn More]     global-imports.js:20:1
ReferenceError: meteorInstall is not defined[Learn More]                 app.js:1:5

I haven’t reproduced your error but why don’t you

meteor npm install mongo-object

to fix the error?

THanks @gigibang it’d been fixed.