Meteor is not recognized as an internal or external command, operable program or batch file on Windows 8.1


#1

This is the output that is showing when I’m trying to use meteor on the command line: ‘“C:\Users\Javier\AppData.meteor\packages\meteor-tool\1.1.8t-os.windows.x86_32\meteor.bat”’

I don’t know what to do and I don’t know how to “play” with the path. Nothing.


#2
  1. Open Control Panel and Select System and Security

  2. Select System

  3. Select Advanced System Settings

  4. Select Environment Variables

  5. Select and Edit Path Environment variable

  6. Append the following to the path variables:

    ;C:\Users\Javier\AppData.meteor\

Hit apply/ok on everything.

Restart your CMD window to pickup the change.

Then check by trying again. If its still not working, veryify the folder location.

Mine is currently AppData\Local.meteor(with the drive and user on the front).

The folder should contain a meteor.bat at its route. Mine looks like:
http://i.ahref.co.uk/u/r/jo1i.png


#3

I’m glad your answer was detailed. Thank you!

I tried everything you wrote and more than that but still says the same. I changed the User variables and the System variables and nothing happend. I have the same location you have of my meteor.bat file. C:\Users\Javier\AppData\Local.meteor

But it seems the output is looking other path ‘“C:\Users\Javier\AppData.meteor\\packages\meteor-tool\1.1.8t-os.windows.x86_32\meteor.bat”’ is not recognized as an internal or external command, operable program or batch file.

I tried placing the meteor.bat file in that location and the output was: “The system cannot find the path specified”.

I don’t know if single or double quote are wrong in the output or that double backslash before packages

‘“C:\Users\Javier\AppData.meteor\\packages\meteor-tool\1.1.8t-os.windows.x86_32\meteor.bat”’

Anyway I don’t know how to edit those single, double quotes or double backslash.

Its weird because I have Meteor on my Desktop without problem on the same OS but in my laptop it doesn’t work although I even reinstalled it.


#4

Just to clarify things, your path variable should link to that top folder not the nested location inside packages.
In the path variable the path should be in a single set of double(") quotes.
Also it needs to be Local\.meteor with the backslash. My full location is: D:\AppData\Local\.meteor Discourse(this forum software) is stripping some backslashes.

So try ;"C:\Users\Javier\AppData\.meteor\" on the end of the path.

Could you also try cd’ing to the AppData\Local\.meteor directory and running meteor from there.


#5

Thank you for your time and trying to help me.

I found the solution reinstalling Meteor on Windows. Now it works without problem.