Meteor.loginWithPassword not triggered


#1

I just figured out that on my last updates of my app I couldn’t login on it using my mobile. I haven’t changed anything related with this and I didn’t update any important or related module.

This is my function:

login() {
      alert('login');
      Meteor.loginWithPassword(this.credentials.username, this.credentials.password, this.$bindToContext((err) => {
      if (err) {
          this.error = err;
      } else {
          Session.set('food',false);
          state.go('food');
      }
    })
    );
  }

This only happens with the app on the Android Market (https://play.google.com/store/apps/details?id=com.drodriguez.recipic), if I try locally it works and also on Desktop. I can only see the alert using the app, but that’s it, the Meteor function doesn’t triggered.

This as I said was working well and I don’t know why it stopped.

Any ideas?


#2

I have similar problem, but with iOS deploy.

try to run your server with parametr

meteor run --mobile-server http://domainexample.com

Use your production server address instead http://domainexample.com

Hope this can help you.


#3

I don’t need to do that, I use pm2-meteor to manage the deployment. Maybe I need to add something else on the config file?

{
  "appName": "recipic",
  "appLocation": {
    "local": "../"
  },
  "meteorSettingsLocation": "../imports/settings.json",
  "meteorBuildFlags": "--architecture os.linux.x86_64",
  "env": {
    "ROOT_URL": "http://www.recipic.co",
    "PORT": 3005,
    "MONGO_URL": "mongodb://localhost:27017/recipic"
  },
  "server": {
    "host": "www.recipic.co",
    "username": "recipic",
    "pem": "../private/recipic_mup_rsa",
    "deploymentDir": "/home/recipic/apps",
    "loadProfile": "",
    "exec_mode": "cluster_mode",
    "instances": 1
  }
}

So having this I only need to run pm2-meteor deploy --reconfig


#4

Have you solved your problem?