Meteor mongo --url just yields a HTML error message

I need to backup my database, so I can either move onto heroku, gallaxy or any other hosting solution. But following the classic
meteor mongo --url
Returns the error message: Couldn’t open a mongo connection

I’ve made sure that the server is awake by browsing to the web view of the app, waiting looooong minutes until it reacts, and then connecting through terminal. No success…

Is there an alternate way of accessing my database?

nevermind… it took a while… a couple of days of trying, but in the end I could connect and get the MongoDB url

I have the same problem, I have been trying more than a couple days, still not working. Is there anything you did to make it work?

just left the terminal open and wait, repeat, wait, and so on…

once I got the url I used the credentials with the 3T db client (can’t
remember the full name now). I used to use robomongo but it doesn’t work

Good luck!!

Thanks, it’s still no luck for me. I think Meteor team should provide support for sites that have trouble connecting their mongodb before they shut down their free tier. It’s not good that developers have no way to get their data back from meteor free server.

maybe you can try accessing the db only after you are certain the server is awake?

Yes, I made sure my site is up before I run the command “meteor mongo --url”, but same problem “Couldn’t open a mongo connection: Service temporarily unavailable. Please try
again later.”