Meteor not working on windows 7, struck at selecting package versions?


#1

Hi,

im new to meteor, i have installed meteor on my windowns 7 machine, when i run “meteor” command it is getting struck at “Selecting package versions /”.

While it is working perfectly fine on my mac.

I tried installing it again, but it is getting stuck at the same place.

Anyone else faced the same issue?

Help!!


#2

Happens to me on a regular basis.
I usually do control-c, meteor reset and relaunch.
If that doesn’t work I delete .meteor/local

Also when a new version of meteor is released, the build fails with a long message ending in - - - -
In that case I delete .meteor/local and if that doesn’t work I reinstall my app from the repo.


#3

Thanks for the tips.

I tried meteor reset and tried deleting the .meteor folder none of it helped.

It is still getting stuck at Selecting package versions


#4

Try to create a new project and copy paste the relevant part of your project in it.

How are you installing the packages ? meteor add or editing the .meteor/packages file ?


#5

It happens to me when i work on my laptop and have restricted internet connection or laptop lag itself.
Other than that, i would probably advise you to update your meteor core. Because you didn’t tell us your version.

It shouldn’t happen at all, actually i had this issue only on 8.1 laptop 2 times or so, but never on win7 PC


#6

When you are developing in Meteor and you add packages, you have to make sure your code runs completely before cutting the internet connexion. NPM packages require 2 runs to update completely.

Also packages that load online ressources (fonts) can hang your application for a while.

That said, the windows port of Meteor is very picky. It stops on a regular basis. And you cannot easily uninstall it, nor reinstall it.


#7

I have the same problem. running on Window 7, installed the latest version.
It could create a new app by “meteor create myapp” on windows cmd, but when I start to run “meteor”, it is stuck at “selecting package versions” seemly forever. Plus, the “slash” symbol is not moving

I have uninstall/re-installed meteor several times.

It ran well a couple of weeks ago, by the way.

I am sure network connection is fine, as when I am posting this problem, it is still being stuck.

Anyway that I can see closely what is happening?


#8

It is happening with me as well.

I’m having a windows 7 laptop, i’m able to create project, but when i try running it with “meteor” command it gets stuck at “Selecting package versions”.

But it is working fine in my mac.

Is there a way to check logs to find out whats going on, all my colleagues are on windows, so i have to make it work on windows, any help is appreciated


#9

I have exact same problem on my windows 7. It passes “Selecting package versions”.and hangs on"Starting your application". Please help.


#10

Finally i was able to solve my problem,

I had to run “meteor update” after installing meteor through installer and everything worked fine.

It should be documented somewhere, or probably should be prompted to the user in the install wizard or it should try to automatically update once installed.

I just wasted a day trying to get it to work, DUH!