Meteor on windows 10 keeps breaking


#1

I am using WebStorm IDE with the meteor plugin.

When I create a project in meteor, or even use the metror CLI, after a while, when it had worked before - the meteor command will stop working and I will get this:


(the error occurs everywhere, in any folder)

I cannot see anything that provokes the error, and all the files are still very much in place:

I have tried doing a manual installation, reinstalling numerous times etc. but none of this seems to resolve the issue.

Also, my PATH is configured correctly.

I am at my wits end here and do not know what to do, any help would be massively appreciated.


#3

Try typing the full path to meteor command.


#4

I have tried this, in the form of “C:/Users/user/AppData/Local/meteor.bat”

I get the same error.


#5

Well never seen this error before. Meteor does not like windows at all to be honest and all kind of weird problems do happen when working on windows. I have shifted to linux for the moment just because of this frustration.


#6

I’m afraid of data corruption with installing a second OS and resizing partitions. Not a route I’m too confident in going down.


#7

Can you check on what place in the .bat file this error occurs.


#8

At risk of sounding like a complete idiot… How would I do this?

edit: just running one more reinstall.


#9

Basically you have to edit your meteor.bat file and put some echo statements in it.


#10

I’m switching to using vagrant instead. This should solve the issue… Currently downloading meteor distriubution.