Meteor project building doesn't like Cordova plugins


#1

I built my application 6 months ago. Today I am trying to release an update. I get this build error while trying to build now:

Error while building for mobile platforms: Error running
/Users/ryanrasmussennew/.meteor/packages/meteor-tool/.1.1.3.1wysac9++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/tools/cordova-scripts/cordova.sh
npm ERR! fetch failed
http://cordova.iriscouch.com/registry/_design/app/_rewrite/de.appplant.cordova.plugin.local-notification/-/de.appplant.cordova.plugin.local-notification-0.8.1.tgz
npm ERR! fetch failed
http://cordova.iriscouch.com/registry/_design/app/_rewrite/de.appplant.cordova.plugin.local-notification/-/de.appplant.cordova.plugin.local-notification-0.8.1.tgz
npm ERR! fetch failed
http://cordova.iriscouch.com/registry/_design/app/_rewrite/de.appplant.cordova.plugin.local-notification/-/de.appplant.cordova.plugin.local-notification-0.8.1.tgz
Error: connect ETIMEDOUT
at errnoException (net.js:905:11)
at Object.afterConnect [as oncomplete] (net.js:896:19)


Fetching plugin "de.appplant.cordova.plugin.local-notification@0.8.1" via
plugin registry

The contents of my cordova-plugins file is this:

com.phonegap.plugins.PushPlugin@https://github.com/phonegap-build/PushPlugin/tarball/1979d972b6ab37e28cf2077bc7ebfe706cc4dacd
cordova-plugin-admobpro@https://github.com/floatinghotpot/cordova-admob-pro/tarball/ced77fcef0a36ba727678795ab1c45b0ac92dfd0
de.appplant.cordova.plugin.local-notification@0.8.1
org.apache.cordova.inappbrowser@0.5.1

Then I ran across a forum on another site that says that Cordova plugins are no longer supported, and to use npm instead.

I don’t know how to install the npm packages into my meteor project. Can someone supply me with the command? And will this solve my problem? Do I need to modify my cordoba-plugins file?

On the website npmjs.com, they give you a command:

npm i cordova-plugin-admobpro

does this command install the package into your meteor project, if you are in your project’s directory?


#2

cordova plugins work for me. Just made another build today.
Make sure you are fetching the right version #


#3

I upgraded my packages to the latest versions, but I am still getting that 404 error, and it won’t build with the cordova packages.


#4

Cordova switched from downloading plugins from its own registry to downloading plugins from npm, but the install process is still managed by the tool. So you won’t have to (or can) install directly from npm. It is up to plugin authors to release new versions to npm.

I’m not sure what is going on in your situation, but it looks like the plugin you are trying to install is only available on npm in a newer version (0.8.2). Could you try updating to that?


#5

I upgraded all of my packages, but I am still getting that error. Do I have to update meteor? The last time I updated my project to 1.2 it broke a lot of stuff.

I can run in my project:
meteor update

Do I also need to update meteor in ~/.meteor?


#6

Have you tried updating de.appplant.cordova.plugin.local-notification to 0.8.2?


#7

Yes I updated it to 0.8.2.

I actually took the error I got from when I removed the admob package, and so I got the same error with the local notification, the one I posted. It accepts the first package in the package list, then stops at 404 not found with the admob package. If I remove the admob package, it throws the same error for the local notifications package.


#8

This now the contents of my cordoba-plugins file:

com.phonegap.plugins.PushPlugin@https://github.com/phonegap-build/PushPlugin/tarball/1979d972b6ab37e28cf2077bc7ebfe706cc4dacd
cordova-plugin-admob@2.9.9
de.appplant.cordova.plugin.local-notification@0.8.2
org.apache.cordova.inappbrowser@0.5.1

It throws the error on the admob package.