Meteor Scaling - Redis Oplog [Status: Prod ready]

Hi,
Is someone else experiencing redis reconnections?
All was working fine until we updated to redis 5.0.8 at Compose. We are using Meteor 2.2 and 2.3 beta
Thanks

Hi, we have many clients on Cloud / Galaxy using redis-oplog and we didn’t receive any issues like this.

So I would say no, at least based on Galaxy clients.

@diaconutheodor hey man - haven’t seen you on here for a while. are you still on Meteor :slight_smile:

Hello @msavin. At our agency we proceeded using our own in-house crafted framework (Kaviar) which has a lot in common with Meteor. Plug-in user system with passport support, GraphQL support, Easy Reactivity (much easier than Meteor), Instant reloads, Full Type-safety everywhere. It’s slowly growing and we are tailoring it to fit our needs, we have a lot of in-house bundles already built-in which help us stay extremely competitive when it comes to pricing. :slight_smile:

2 Likes

I just installed Redis Oplog for the first time. Deployed on Galaxy.

I have both the main package and disable-oplog installed.

But on our database (MongoDB Atlas) it still seems the database is still constantly using Oplog operations as the largest amount of load?

Should I remove the MONGO_OPLOG_URL from settings.json? Or any advice?

(Edit: Also, I saw comments that the APM should be listing the Redis stats. I don’t see anything on the Galaxy APM for this? And to confirm, the Redis connection has been established according to Galaxy, and I do see the graphs on Redis going…)

MongoDB uses oplog as well.

You don’t need to have MONGO_OPLOG_URL in your settings anymore.

If you have specific questions about Galaxy/APM feel free to open a ticket at support@meteor.com so we can analyze your case

2 Likes