Meteor tool stuck when downloading meteor-tool@1.3.2_4


#1

Once I try to start a new Meteor project (using just meteor create ) tries to download Meteor 1.3.2_4, as expected, but it never seems to finish downloading.

The first step of the download, the part that shows the download bar, works as expected. The download starts and goes all the way to 100%, and then it goes to the second stage with the rotating line, like so:

At the time of writing, the download has been on that state for around half an hour. Not sure how to proceed, any help will do!

Thank you


#2

I suggest waiting it out. Long update times have been reported. I’ve seen updates taking 1 minute and taking upwards of 30 minutes. Others have seen even longer, especially on Windows.

I’ve seen better times by completely removing meteor and re-installing from scratch - so that may be worth trying.


#3

You were right. I set it to download during the night, and by the morning the download ended.


#4

Wasted an entire day on this !! I hope it downloads overnight. :frowning: :frowning:


#5

I am having the same problem. Download overnight didn’t work either. I also tried to delete the .meteor folder completely in /AppData/Local and reinstalling meteor. Nothing seems to help… I am using Win10.
This affects all meteor apps old ones aswell as new ones.
I noticed however, that when I newly create a meteor app using meteor create and then run that newly created app, everything works fine.
I need to get the old ones running though :frowning:


#6

did it work for you @sathishc?


#7

Yes it did. It took almost 2 hours in a 2 mbps broadband connection. I was thinking it hung and kept trying different things like changing nodejs version until I found this post. Thanks !


#8

This is killing all the time I “gain” by using Meteor… :frowning:


#9

I am having this problem and I noticed that the Antimalware service was pegging my CPU. I am pretty sure it is checking all of the downloaded files and is holding up the progression of the install. So this is by design for windows! In some ways I like it, in others it is a pain.


Meteor hanging at 'starting your app' / patch 1.4.2.5
Can't install Meteor on Windows 10 "Please Wait"
#10

Mine was it was almost half a day. I’m stucked up


#11

Does anyone have any solution? I’m getting impatient here…


#12

No luck on my home cable Internet. Ran overnight to no avail. Had better luck at my office where we have a commercial fiber optic line. It installed in a few minutes. I’ll probably have to take my home pc to the office tomorrow. Fortunately, I can work remotely or it would be a disaster.


#13

Left the computer to run overnight and still no luck.
Is there any way to check if what the problem is?


#14

I am having this issue… very frustrating

 Downloading meteor-tool@1.3.4_1...        |

#15

Me too, I’m on Windows 7. It’s very frustrating, it’s been like this for a few days now, what’s the official answer to this?


#16

same for me, it’s been two days that I try to update 1.3.4_1


#17

Same for me too… Is there a way to download manually?


#18

I got it to download by adding 54.192.225.217 warehouse.meteor.com to /etc/hosts https://github.com/meteor/meteor/issues/6960


#19

Phew, on ubuntu i added 54.192.225.217 warehouse.meteor.com to /etc/hosts and worked like a charm.
Thanks @tberghuis


#20

I can confirm what @brucejo said about the antimalware service. Deactivate windows defender temporarily and you are all set!