Meteor-Up (mup) error after "mup init"


#1

I am trying to use mup to deploy a meteor app to my DigitalOcean droplet.

What I have done so far

  • Followed instructions on “Meteor-Up” website http://meteor-up.com/getting-started.html.
  • Installed mup via “npm install --global mup”
  • Created “.deploy” folder in my app directory. Ran “mup init”.
  • Configured file “mup.js” file for my app, ran “mup setup”.

Here is where I ran into an error. Upon running “mup setup”, I am hit with the following error.
mup_error

What I tried:
I suspected that there could have been an issue with my syntax when configuring the mup.js file. After double-checking and not finding any error, I decided to re-install mup, and try running “mup setup” without modifying the “mup.js” file. However, I still receive the same error message.

Furthermore, after running “mup init”, I can no longer run “mup” either, as I receive the same error as seen above. I suspect therefore that the issue is with the mup.js file. I have attached the generic version provided by meteor-up below (which still causes the error seen above).

module.exports = {
  servers: {
    one: {
      // TODO: set host address, username, and authentication method
      host: '1.2.3.4',
      username: 'root',
      // pem: './path/to/pem'
      // password: 'server-password'
      // or neither for authenticate from ssh-agent
    }
  },

  app: {
    // TODO: change app name and path
    name: 'app',
    path: '../app',

    servers: {
      one: {},
    },

    buildOptions: {
      serverOnly: true,
    },

    env: {
      // TODO: Change to your app's url
      // If you are using ssl, it needs to start with https://
      ROOT_URL: 'http://app.com',
      MONGO_URL: 'mongodb://localhost/meteor',
    },

    // ssl: { // (optional)
    //   // Enables let's encrypt (optional)
    //   autogenerate: {
    //     email: 'email.address@domain.com',
    //     // comma separated list of domains
    //     domains: 'website.com,www.website.com'
    //   }
    // },

    docker: {
      // change to 'abernix/meteord:base' if your app is using Meteor 1.4 - 1.5
      image: 'abernix/meteord:node-8.4.0-base',
    },

    // Show progress bar while uploading bundle to server
    // You might need to disable it on CI servers
    enableUploadProgressBar: true
  },

  mongo: {
    version: '3.4.1',
    servers: {
      one: {}
    }
  }
};

#2

When using Command Prompt, you should use mup.cmd instead of mup. For example, mup.cmd setup.