Meteor update 1.2.1 - with Telescope 0.25


#1

Hi there guys.

So I recently updated to 0.25 on Telescope updating Meteor to version 1.2.1.

I ran into a multiple minifier issue. once I remvoed the unnecessary minifier, I got a new error which looks like this:

=> Errors prevented startup:                  

While processing files with fourseven:scss (for target web.browser):
/packages/company-branding/lib/client/stylesheets/custom.scss: Scss compiler error: 
File to import: {company-branding}/lib/client/stylesheets/variables not found in file: 
/home/jonathan/Projects/cx.io/app/{company-branding}/lib/client/stylesheets/custom.scss

I have tried using this:

@import '{company-branding}/lib/client/stylesheets/_variables.scss'

However the issue is still not being resolved.

Any support?


#2

Hi Jonathan,

I spent hour or so trying to fix same issue. I followed instructions on the fourseven:scss package page and tried relative path, but with no luck. I think this is a fourseven:scss package bug. For now the acceptable solution for me was to change “api.use([‘fourseven:scss’])” to “api.use([‘fourseven:scss@3.2.0’]);”. Disclaimer: package authors claim versions >= 3.3 to be optimized and targeting Meteor 1.2, so have it in your mind when you use older version.
Hope this helps!