Meteor update doesn't work


#1

the console told me that i should run meteor update.

so i did.
now it is stuck (keeps spinning) at “Extracting templating @1.1.9.”

what can i do?

any help is superhighly appreciated.

oh, meteor!
m!


#2

i also couldnt update to 1.4 Looks like there will be a split your current app might have to stay in 1.3 untilwe workout how to use 1.4.


#3

To update my app to 1.4, i had to completely wipe my app, then my meteor installation, reinstall everything then recreate the app from repos. This was not a pleasant experience…


#4

It seems to be the same problem that i have when trying to install angular templates:


I’m trying to install Meteor w/angular flavor, following meteor tutorial steps.

Excluding blaze-templates was OK, but when i try to install angular templates, the install processing ‘stalls’ in loop like:

H:\Radar>meteor add angular-templates
Extracting angular-templates@1.0.9… / (for ever).


The problem is in meteor add function (update too). I tried to install version 1.0.7 too with same result.


#5

Things to try (using Linux/OSX):

Reinstall Meteor (anywhere):

rm -rf ~/.meteor
curl https://install.meteor.com/ | sh

Reset your app (inside your app directory, warning: this also resets internal MongoDB if you use it):

meteor reset

#6

yes ! same problem, extracting templating@1.1.9 after 25 minutes when i broke the update ^C^C seems the problem is coming from node.exe in
C:\Users\Pc_user\AppData\Local.meteor\packages\meteor-tool\1.4.2\mt-os.windows.x86_32\dev_bundle\bin