'meteor update' in 1.3.1 not detecting 1.3.2

I noticed once when I ran meteor that it stated 1.3.2 was available and that it was downloading it in the background. At some point I ctrl-c’d that session. Now, meteor is no longer saying anything about 1.3.2 being available when I run it and ‘meteor update’ says that 1.3.1 is the latest version. The changelog does indicate that 1.3.2 has been released though…

Did I break something by killing meteor while it was downloading in the background? How do I recover? Is this perhaps a blessing? (I’m writing mocha test and I noted something about a bug in testing with 1.3.2)

rlivingston@dreamshot:~/oob/meteors/oob$ meteor update
This project is already at Meteor 1.3.1, the latest release.
Your top-level dependencies are at their latest compatible versions.
Newer versions of the following indirect dependencies are available:
 * npm-bcrypt 0.7.8_2 (0.8.5 is available)    
To update one or more of these packages, pass their names to `meteor update`.

I also have issues with mocha and flow-router and hoped that 1.3.2 would solve this. Thus I did:

meteor update --release METEOR@

Yup, there’s a patch available.

But that didn’t solve my issue. I’ll post another topic on this.

1 Like

Same here. even after using "meteor update --release"
and then running “meteor --version” it shows 1.3.1

I’m having the same issue.

meteor update --release METEOR@ worked for me.

So, I forced using meteor update --release and can confirm that my server-side mocha tests are no longer running in So, that’s a dead release to me.

And as stated by sami above, meteor update still shows 1.3.1 as being the recommended release.

rlivingston@dreamshot:~/oob/meteors/oob$ meteor update
Not updating the release, because this app is at a newer release (METEOR@ than the latest
recommended release (METEOR@1.3.1).
Your top-level dependencies are at their latest compatible versions.

But, is that word “recommended” the key? Have they either pulled 1.3.2 as a recommended release or, perhaps even more intelligently, is the release logic sophisticated enough to recognize that I’m using mocha and trying to stop me from hurting myself?

If this is intentional behavior, perhaps better messaging when I’m on 1.3.1 would be in order. Something like, “A newer release,, is available but is not recommended for your configuration due to known conflicts with one of your packages.”

I downgraded back to 1.3.1. After doing so, my mocha tests are again running and the ‘meteor update’ command is back to just saying that 1.3.1 is the latest release.

I’m not dying because of this, always plenty to do. But I’d love an answer from an expert as to whether this is all expected behavior or an issue. Perhaps they actually pulled both 1.3.2 and due to issues? A complete failure in one of the main focal points of the 1.3 series, testing, is certainly a major one and I wonder why it would get past release testing.

I’m going to publish another release ( today, including a fix for this bug, which may be relevant for the testing problems mentioned above.

Thanks! Looked at the fix and understand the testing issue. We all have these little oversights from time-to-time :slight_smile:

Now that came out, I understand everything that happened.

When appeared, ‘meteor’ detected it and ‘meteor update’ worked fine. It is apparent that 1.3.2 was “recommended” for a short time during which I noticed it and then the recommendation was pulled. Once became “recommended”, everything was great.

It would have been nice for the changelog to say that 1.3.2 and were not recommended. Or perhaps there is some other place I should just “know” to look for such things?

In any case, all’s good, I’m updated and my server-side tests are running.