Meteor upgrade to 1.10 fails

Trying to upgrade meteor windows 10 install to 1.10. Currently it is 1.9.2. And Chocolatey is v0.10.15.
When I try an upgrade in PowerShell as admin user, I get

PS C:\WINDOWS\system32> choco upgrade meteor
Chocolatey v0.10.15
Upgrading the following packages:
By upgrading you accept licenses for the packages.
meteor v0.0.2 is the latest version available based on your source(s).  

Chocolatey upgraded 0/1 packages.
 See the log for details (C:\ProgramData\chocolatey\logs\chocolatey.log).

Then I decided to try the uninstall/install route

PS C:\WINDOWS\system32> choco uninstall meteor
Chocolatey v0.10.15
Uninstalling the following packages:

meteor v0.0.2
The package meteor wants to run 'chocolateyuninstall.ps1'.
Note: If you don't run this script, the installation will fail.
Note: To confirm automatically next time, use '-y' or consider:
choco feature enable -n allowGlobalConfirmation
Do you want to run the script?([Y]es/[A]ll - yes to all/[N]o/[P]rint): y

Removing the Meteor data directory...
Chocolatey timed out waiting for the command to finish. The timeout
 specified (or the default value) was '2700' seconds. Perhaps try a
 higher `--execution-timeout`? See `choco -h` for details.
meteor uninstall not successful.
Error while running 'C:\ProgramData\chocolatey\lib\meteor\tools\chocolateyuninstall.ps1'.
 See log for details.
meteor not uninstalled. An error occurred during uninstall:
 meteor uninstall not successful.
Environment Vars (like PATH) have changed. Close/reopen your shell to
 see the changes (or in powershell/cmd.exe just type `refreshenv`).

Chocolatey uninstalled 0/1 packages. 1 packages failed.
 See the log for details (C:\ProgramData\chocolatey\logs\chocolatey.log).

 - meteor (exited -1) - Error while running 'C:\ProgramData\chocolatey\lib\meteor\tools\chocolateyuninstall.ps1'.
 See log for details.

If a package uninstall is failing and/or you've already uninstalled the
 software outside of Chocolatey, you can attempt to run the command
 with `-n` to skip running a chocolateyUninstall script, additionally
 adding `--skip-autouninstaller` to skip an attempt to automatically
 remove system-installed software. This will only remove the packaging
 files and not things like software installed to Programs and Features.

If a package is failing because it is a dependency of another package
 or packages, then you may first need to consider if it needs removed
 as it is typically installed as a dependency for a reason. If you
 decide that you still want to remove it, head into
 `$env:ChocolateyInstall\lib` and find the package folder you want
 removed. Then delete the folder for the package. This option should
 only be used as a last resort.

PS C:\WINDOWS\system32>

And now I get this

PS C:\WINDOWS\system32> meteor --version
The system cannot find the path specified.
PS C:\WINDOWS\system32>

The method of upgrading meteor should be properly and clearly documented on This has been a gap in meteor documentation for a long time. Currently this appears to be the most up to date migration documentation -
And I have wasted too much time at various stages trying to go from meteor version x to version y. With the result that my live meteor-driven website is stuck at version 1.8.1. Or if its a case that meteor doesn’t reliably function on Windows then this should be made clear.

Install meteor again using chocolately.

When you want to upgrade meteor, go into your project and run meteor update --release 1.10.1.

You’ll probably need to restart your computer now, though. Since it seems like your paths are all messed up.


This is just an ancedotal comment but

I also develop on Windows and have never used Choco for meteor aside from the initial installation. I’m not saying that won’t work, because I don’t know, but I’ve always updated using meteor commands.

‘meteor update’ usually works as long as the version you want to update to is reccommended (Which currently 1.10.1 is). Otherwise you’ll need to include a version argument

An important sidenote though, on Windows I have had the upgrade stall (Maybe around 50% of the time). When this happens, interrupting it and running the same command again (meteor update) works and completes the update. I usually judge whether or not the update has stalled by looking at task manager and seeing little to no activity for an extended period of time.


I tried restarting pc and installing meteor again but no joy even after physically removing C:\Users\myuser\AppData\Local\.meteor\. I will try to upgrade project once the I fix the meteor install issue presuming meteor will allow me to go from 1.8.2 to 1.10.1 using meteor update --release 1.10.1.

A good point around not using Choco for meteor as it doesn’t seem able to detect that there was a new version of meteor to install. Perhaps the install is corrupted in some other way. But I think I will take your advice and leave the Choco install alone once stable again.
As you say there are major issues with meteor update on Windows. Perhaps meteor will address them at some stage.

The chocolatey script should probably have a separate upgrade path for issues like this, where it finds an installed meteor version and runs meteor update instead of uninstall/reinstall

Also looks like it needs a longer timeout!

1 Like

I solved the issue and managed to install meteor 1.10.1 on Windows 10 by following the below steps.

  1. Deleted the meteor AppData folder -> C:\Users\myuser\AppData\Local.meteor\

  2. Uninstalled Chocolatey by deleting the C:\ProgramData\chocolatey folder and removing relevant environment variables -> Chocolatey Uninstall

  3. Re-installed Chocolatey from Powershell (running as admin) -> Chocolatey Install

PS C:\ProgramData> Set-ExecutionPolicy Bypass -Scope Process -Force; [System.Net.ServicePointManager]::SecurityProtocol = [System.Net.ServicePointManager]::SecurityProtocol -bor 30** **72; iex ((New-Object System.Net.WebClient).DownloadString(''))

Verified the Chocolatey install

PS C:\> choco 
Chocolatey v0.10.15
  1. Installed meteor
    PS C:\> choco install meteor

Validated meteor install

PS C:\WINDOWS\system32> meteor --version
Meteor 1.10.1
PS C:\WINDOWS\system32>

Now I just need to update my project from to 1.10.1!

Thanks everyone for all the feedback!