Meteor will not install on Windows 10; can't get either MSI or packages manual install to work. Help?

I’ve been at this for a couple hours now and thought I’d try here since a forum search turned up nothing.

Has anyone got Meteor to install and run cleanly on a Win 10 machine? Am I perhaps having a conflict w/ my existing Nodejs install??

The MSI seemed to complete just fine, but the command meteor wasn’t recognized. In the add/remove apps window it was there, but reportedly only occupied 827Kb. That didn’t look correct.

I tried what abernix suggests in the link below (a couple of times) w/ no luck

If anyone has an approach that worked for them, I’d love to hear about it. Thx.

I have a working installation on Windows 10. My installed Meteor app says it occupies 827KB.

To get the meteor command to work, did you reboot? Log in/out? start a new cmd window?

Did you install meteor as an admin user? I have heard this can be trouble for some people.

Running on Windows 10 for a long time, never an issue.

Definatly reboot for the command line to work, as it adds to windows global variables.

Thanks for getting back guys. I appreciate the insight.

@brucejo - thanks for the confirmation re: install size. I restarted cmd win, rebooted, etc., but still dead. Meteor command never recognized. I did not install meteor as an admin user, but thought I might try that. I suppose now I won’t. Thank you for the insight

@SkyRooms - thanks for the input. I’m going to keep trying

I took a look at my environment variables. Do you have this on you path variable?


The meteor command is here: C:\Users\<username>\AppData\Local\.meteor\meteor.bat

1 Like

Hey Brucejo!

Thanks man!! So, I didn’t have the environment variable set. Boom!!

Also, I didn’t understand that the ‘meteor’ command is only valid w/in the meteor directory. I’ve been more exposed to globally installed tools which will return a version number from any directory.

Looks like I have it installed now, but it only returns a valid version w/in the meteor folder. Is this correct?

No it is not correct. You should be able to execute meteor -v anywhere in your environment. Meteor install should set the environment variables for you.

Meteor will execute differently in a meteor directory because each meteor project can have different versions of meteor installed. The global command examines your location and figures out if it is a meteor project and if it is a project it executes commands from the bundle in the .meteor directory.

I assume you have uninstalled and then done a reinstall? Sounds like your install did not perform as expected.

Can you share what your path variable looks like? set PATH in command window.
Also, what do you get when you type where meteor.

I’ve had troubles on Win 10 for a long time. Have you tried using the Ubuntu environment built into Win 10 now? It works really well and is seamless.

YES! Sorry this was the issue that I had as well. Globals didn’t get installed because I didn’t install as admin.

I only run Meteor inside my project directories… Hrm no wait, I eventually got it working.

Welcome to Meteor. If you think installing it was fun, good luck… with everything else! I’ll save you some time, check out Cloudinary for image hosting. It’s the easiest… but still takes days to understand. Hopefully you’re smarter than me and breeze thru. Good luck :smiley:

1 Like

Thanks @SkyRooms! That jogged my memory…

Yes, when installing Meteor the best technique is to:

  1. Not be logged in with an admin account.
  2. Right click installMeteor.exe and choose run as administrator.

Then all the code will install in your User directory, but the app will be able to modify global variables like the path. Sorry for the run around.

Thanks for all the help you guys!!! I did uninstall and reinstall… and this morning went through the whole process again in an attempt to get it running.

I now have it installed and get valid version response from anywhere in the environment. My hunch is the same as yours in that my install didn’t go smooth initially.

Strangely, my Git bash cannot see it, but Win Cmd does, so I figure that is a Windows quirk. At this point I’ll live with it as long as I can start learning some Meteor.

Thanks again for all the help and suggestions everyone! I’ll check back in if things aren’t actually running correctly… hoping for the best!

In Git bash, try using meteor.bat and it should work.

1 Like