Meteor won't refresh when running MongoDB


#1

Hi,
I can’t get Meteor 1.4 to refresh if I have the MongoDB shell running. I just get a message saying:

=> Client modified – refreshing

First time this happened, I just went to work and came back and saw that it was stuck, So I did a reboot since I needed to do one anyway.
After that, tried a second time and started MongoDB and added an item to it successfully through the shell and edited some HTML and saved. Got the refresh message sitting there so I googled and waited for about 10 minutes and got nothing. Went shopping and thought what might happen if I stopped MongoDB and tried it when I got home, cause it was still stuck.

Upon closing MongoDB shell, the project did a rebuild immediately. Not sure what’s happening, but I can’t get MongoDB to work.

Xubuntu 16.0x
AMD 8-core CPU @ 3.2 GHz
32GB RAM
SSD


#2

Are you using meteor mongo command to run the MongoDB shell? I cannot reproduce your issue with my app.


#3

what cmd are you using to launch your app?


#4

in my project directory I type meteor
in a new tab i type meteor mongo


#5

Are there other options aside from the forums?


#6

You can file an issue on Github. Just make sure to describe your issue with as much details as possible (your configuration, etc).


#7

We can reproduce it on Mac. Most important change we made is update of npm mongo-npm. Did you by accident also do that update @laserbeak43 ?


#8

Sorry I’ve missed this. I cannot see how I might have updated Mongo at all.
Seems Meteor has issues being future proof? I wish I had the skill to contribute to its maintenance. At this point, I don’t think that Meteor is for me. Maybe one day.