Meteor won't start, everything is 'undefined'


#1

As I was testing some features I added to my website on the localhost version of Meteor, it suddenly broke. Here’s a sample of the logged errors in my web browser console:

Uncaught ReferenceError: Package is not defined meteor.js:21
Uncaught ReferenceError: Package is not defined json.js:21
Uncaught ReferenceError: Package is not defined base64.js:21
Uncaught ReferenceError: Package is not defined ejson.js:21 
Uncaught ReferenceError: Package is not defined reload.js:21 
Uncaught ReferenceError: Package is not defined tracker.js:21 

There are about 142 other error messages just like the ones above, including “Template is not defined” for the templates in my project.

I decided to update Meteor to version 1.1.0.3 (was originally working on version 1.1.0.2) thinking that it would fix the problem, and yet the errors still persisted. Then I did a complete uninstall/reinstall with no luck. I even created a new project to test if the error was related to the actual code in my project or Meteor, and surprisingly enough, the errors persisted in the testsite (I simply typed into terminal meteor create testsite, than ran meteor in the new directory).

Any help would be much appreciate! I really can’t do much work on this project with these errors. I apologize in advance if this is a simple-to-fix error, but I am relatively new to using Meteor.


#2

How does your .meteor/packages file look? It could be that your meteor-platform is missing?

Try doing the following:
Make a backup of your .meteor directory.
then do “meteor create” again, and try running it. Of course packages will be missing etc, but I have a feeling either meteor-platform is missing or your .meteor directory is corrupted.
If this works, just copy your packages of choice from .meteor/packages over to the new project.


#3

did you try clearing your browser cache?


#4

I had a similar issue recently. It turned out the file system was full.


#5

Just tried this out and it worked! Not too sure why this was the solution though, care to explain?


#6

I’m very sorry but the title of this thread made my day.


#8

not sure exactly. I had the same issue before. may be chrome sometimes caches incompletely.


#9

Same issue after update Meteor to 1.1.0.3


#10

In my case the problem was when updating materialize package.

worked ok w/ 0.97.0

meteor remove materialize:materialize
meteor add materialize:materialize@=0.97.0


#11

Me too.
Solution : change defaut port 3000


#12

This solved it for me, so is that package broken still?