MeteorAngular Tutorial: Strange MongoDB behavior


#1

I am working through the AngularMeteor tutorial found at angular meteor tutorial link.

On step 3, collections. I get strange results.

I am on OSX yosemite, meteor 1.2.1 and WebStorm 10 IDE.

When I type “meteor mongo” I get the mongo CLI listed as "meteor:PRIMARY> "

If I type
db.tasks.insert({“text” : “A new party”, “description” : “From the mongo console!” });
and then type db.tasks.find();
I get back
{ “_id” : ObjectId(“563c1a48d880b1f80bdb1fa2”), “text” : “A new party”, “description” : “From the mongo console!” }

If I then run the example as shown in step 3 (no edit, no create, just let the example reload after making the changes as shown in step 3) I get
{ “_id” : ObjectId(“563c1a48d880b1f80bdb1fa2”)}

Strangely, any ensuing insert call will also show a result similar to above.

What am I missing?


#2

I’ve witnessed the same issue, I fixed it by downgrading the angular package to 1.0.4 and resetting meteor…

meteor remove angular
meteor add angular@=1.0.4
meteor reset

#3

do the same but for the latest version 1.0.6.
Please let me know if that worked for you


#4

YAY! It works…

I appreciate the time and help from both of you.

Is there a tl;dr version of why this fixed things?

Thanks again.


#5

@Urigo - Thanks, can confirm the upgrade also works for me


#6

You check check out the release notes: https://github.com/Urigo/angular-meteor/releases