Meteormocha TEST_WATCH not working


I’m having the same issue as seen Following tutorial, 'TEST-WATCH' is not recognized as an internal or external command, operable program or batch file . I then followed what fixed it for the user to no avail.

I’m running Win 10. On cmd prompt I run ‘setx TEST_WATCH 1’ which returns with ‘SUCCESS: Specified value was saved.’. I then restart my computer. To ensure the env var got saved, I run ’$env:TEST_WATCH’ which then returns the correct value of ‘1’.

So it seems like the env var is getting set correctly. However, I then try to run ’ TEST_WATCH=1 meteor test --driver-package meteortesting:mocha’ in my project directory and still get

’TEST_WATCH=1 : The term ‘TEST_WATCH=1’ is not recognized as the name of a cmdlet, function, script file, or operable
program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.'

Any ideas ?

Nevermind, looks like ‘TEST_WATCH=1’ has to come as an argument to ‘meteor test’. Makes complete sense, just that the documentation has the env var first