Migrating meteor 1.2 app to meteor 1.3


#1

hey guys, I am migrating meteor 1.2 app to meteor 1.3. and I have got some errors:

While processing files with cosmos:browserify (for target web.browser):
   packages/kadira:dochead/package.browserify.js: Cannot find module
   'load-script' from
   '/home/deligence/.meteor/packages/kadira_dochead/.1.3.2.joh5qz++os+web.browser+web.cordova/npm'

I tried to sort it out by updating cosmos:browserify package but then got error:

While building package elibrary:landing:
   lib/views/search/request-modal/request-modal.jade: Jade syntax error:
   Expected identifier, number, string, boolean, or null
   {{#if @index}}
   ^
   packages/compileJade/plugin/handler.js:54:1: Cannot read property 'head' of
   undefined (compiling lib/views/search/request-modal/request-modal.jade) (at
   fileModeHandler)
   lib/views/search/search.jade: Jade syntax error: Expected IDENTIFIER
   remove-filter-{{@index}}
   ^
   packages/compileJade/plugin/handler.js:54:1: Cannot read property 'head' of
   undefined (compiling lib/views/search/search.jade) (at fileModeHandler)

On removing my local package from .meteor/packages I got error in fiber.js

Does anyone have any idea what the problem is?


#2

A patch for this was recently applied to kadira:dochead - see:


#3

Hi hwillson,

Thanks for your response,

I have visited the link still not working

  • remove symlink, causes recursive error ----> I have removed local folder from my meteor
  • update version 1.5.0, Meteor dependency to 1.3 ----> Not understood exactly what should I do
  • remove cosmos:browserify dependency ----> I don’t have browserify as an independent package and I want to use routing in my project removing flowrouter will not solve my problem
  • rename browserify.js to main.js ----> I don’t have browserify.js in my project

What should I suppose to do?


#4

You should just be able to update the kadira:dochead package (to the latest 1.5.0 version) to get the fix. Which version do you show as having installed in your .meteor/versions file?


#5

I had 1.3.1. Now I have updated it and getting error:

Error: Can't find npm module 'request'. Did you forget to call 'Npm.depends' in package.js within the 'aldeed_http' package?