Missing tarball for 2.0-beta.x

When running the install script from https://install.meteor.com wanting to install the 2.0-beta.1 version I get “curl (22) 403 Access Denied”.

Looked into the *.sh found that the tarball is set here


Since I’m on macOS I’ve tried running with PLATFORM = os.osx.x86_64


Assuming the Release I want is any of the 2.0-beta.x I tried
https://static-meteor.netdna-ssl.com/packages-bootstrap/2.0-beta.1/meteor-bootstrap-os.osx.x86_64.tar.gz and surely enough Access Denied.

I’m running the install script in CI, and giving the release paramater the value of 2.0-beta.1 so the command that ends up running is
curl https://install.meteor.com/?release=2.0-beta.1 | sh

Am I passing the wrong format for Release? is the tarball missing?
Any help is appreciated, thanks.

1 Like

Hi, we usually don’t publish tarballs for betas. Do you need to install using the tarball? If so, let me know.

Hey there filipe, thanks for the answer.

I’m currently using Github Actions for our CI solution and using this action to set up Meteor. It executes the bash from https://install.meteor.com/ so it indeed does try to get the tarball.

We are planning to migrate our environment to Meteor 2.0-beta to take advantage of the much needed HML, and I would like our CI to be running on the same Meteor version as our development and product will so that we could test closer to the source of truth.

So I would say that “Yes”, we need to install using the tarball.

Any help would be much appreciated.

Any chance for publishing the tarballs, Filipe ?

We usually don’t publish tarballs of betas and the production bundle will not be affected by this beta that only includes HMR but in any case I published yesterday 2.0-beta.3 tarballs.

Next betas will also include tree-shaking and other news :wink: